php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56359 ps_get_buffer omits data
Submitted: 2005-03-27 07:14 UTC Modified: 2006-02-21 07:24 UTC
From: simonb at netstacker dot de Assigned: steinm (profile)
Status: Closed Package: ps (PECL)
PHP Version: 4.3.10 OS: Debian Sarge x86
Private report: No CVE-ID: None
 [2005-03-27 07:14 UTC] simonb at netstacker dot de
Description:
------------
When using ps_get_buffer() to output a small document into a string, only the beginning of the document is returned. Later parts are omitted.
It seems to work fine if the document is written to a file.

Reproduce code:
---------------
http://www.netstacker.de/tmp/ps_get_buffer.php.txt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-21 07:24 UTC] uwe at steinmann dot cx
ps_get_buffer() isn't implemented yet and you actually don't need it, because the ps document is send to stdout anyway if you don't pass a file name to ps_open_file(). The fact that your script quits in the middle of the ps file, is probably due to a bug in pslib which lets you access its internal string buffer (via ps_get_buffer()) while it is uninitalized.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 21 12:01:22 2019 UTC