php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56333 unable to upload PECL packages
Submitted: 2005-02-26 22:04 UTC Modified: 2005-02-26 22:39 UTC
From: gabe@php.net Assigned:
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS: mac os x
Private report: No CVE-ID: None
 [2005-02-26 22:04 UTC] gabe@php.net
Description:
------------
I uploaded intercept-0.1 earlier today, worked fine. I 
made some modifications and created an 0.1.5. I tried to 
upload it to pecl.php.net and received the following 
error:

ERRORS:
You must correct your package.xml file:
Only channel pecl.php.net packages may be released at 
pecl.php.net

Release type php is not supported at pecl.php.net, only 
Extension releases are supported. pear.php.net supports 
php packages


I tried making changes to the package.xml file, and 
looked at the version from pecl.php.net/dtd/ and still 
no luck. Wez suggested I submit a bug report here 
because PEAR was updated on the pecl.php.net server and 
that may be causing this upload problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-26 22:39 UTC] cellog@php.net
Upload your release through pear.php.net and it will work - I will add a helpful note in release-upload.php.

Alternatively, use "pear convert" with PEAR 1.4.0a1 to create your package2.xml and package with

"pear package package.xml package2.xml"

and then upload will work
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 10:01:26 2019 UTC