php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56320 Compile Problems and wrong versionstring
Submitted: 2005-02-22 10:05 UTC Modified: 2005-03-08 07:04 UTC
From: joerg@php.net Assigned:
Status: Closed Package: pdflib (PECL)
PHP Version: Irrelevant OS: IRIX 6.5.27m
Private report: No CVE-ID: None
 [2005-02-22 10:05 UTC] joerg@php.net
Description:
------------
Cant compile latest pdflib-2.0.4 using old style way with 
using phpize and configure.
Same error occurs when using the pear installer on a gentoo linux machine. The string in pdf.c:67 also shows an older version 2.0.3 and not 2.0.4
  

Reproduce code:
---------------
[o2k]:/usr2/MIPS/php5-200502221330/ext/pdf
./phpize
./configure  --with-php-config=/usr/nekoware/php5/bin/php-config --with-pdflib=/usr/nekoware

cc-1005 cc: ERROR File = /usr2/MIPS/php5-200502221330/ext/pdf/pdf.c, Line = 91
  The source file "ext/gd/php_gd.h" is unavailable.

  # include "ext/gd/php_gd.h"
                             ^
The pecl package was extrated in the php srctree an renamed into the old name.

regards
Joerg

Expected result:
----------------
Clean compile

Actual result:
--------------
Compiler Error

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-08 07:04 UTC] rjs at pdflib dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Fixed the version string,
and GD Support is no longer included by default, because there is not yet a solution that PHP reliable has the gd header files installed.

If one still wants to use the inofficial API pdf_open_memory_image() he has to set the define PDFLIB_WITH_GD_SUPPORT manually.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 09:01:24 2020 UTC