php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56281 Triple size reducing makes manual code snippets and bug reports unreadable
Submitted: 2005-02-01 22:02 UTC Modified: 2006-02-18 08:57 UTC
From: plyrvt at mail dot ru Assigned: pajoye (profile)
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS: win32
Private report: No CVE-ID: None
 [2005-02-01 22:02 UTC] plyrvt at mail dot ru
Description:
------------
CSS styles used at website are not properly hanled by Opera browser (7 and 8beta versions under win32). This is due to Opera do not work correctly with 
.css {font-size: nn%}
sizes in percents.
All text inside <pre> tags (at code listings in manual and text in bug reports) becomes too small and hard-readable.

Reproduce code:
---------------
Here is screenshot how it looks normally in IE/FireFox (below) and hard-readable in Opera7/8-win32 (top) http://rv.uar.net/~yp/opera.jpg

Expected result:
----------------
The easiest way to fix opera-related problem is to set in 
http://pear.php.net/css/style.css
code, pre, tt {
    ...
    font-size: 90%;
}
to 
code, pre, tt {
    ...
    font-size: 93%;
}

For other browsers there won't be impact, but Opera will render code as expected.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-20 21:06 UTC] plyrvt at mail dot ru
I've cut PEAR manual design to this lines to highlight where is the bug (also it can be seen with Firefox 1.0)
"Some text" is very small (72%=0.9*0.9*0.9) because of triple (!) overlapping of CSS's size reduce

<html>
<head>
<style>
body {
    font-size: 90%;
}
code, pre, tt {
    font-size: 90%;
}
</style>
</head>
<body>
<pre><code>Some Text
Some Text
Some Text
</code></pre>
</body>
</html>
 [2006-02-18 08:57 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PEAR itself.  For a
list of more appropriate places to ask for help using PEAR, please
visit http://pear.php.net/support/ as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PEAR.

report the bug to opera then.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu May 23 23:01:26 2019 UTC