php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56247 PATCH: Link to package page from bug reports
Submitted: 2004-12-15 14:45 UTC Modified: 2004-12-15 15:04 UTC
From: aaron dot hawley at uvm dot edu Assigned: danielc (profile)
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 4.3.4 OS: GNU/Linux
Private report: No CVE-ID: None
 [2004-12-15 14:45 UTC] aaron dot hawley at uvm dot edu
Description:
------------
It would be convenient for users if they could navigate between the bugs for a package and the package's home page and documentation, etc.  Thankfully the URL system makes it easy to do.  A patch follows to the CVS version of the PEAR web site.

Reproduce code:
---------------
http://www.uvm.edu/~ashawley/php/pear/bug.php-package_link.diff-u

Index: bug.php
===================================================================
RCS file: /repository/pearweb/public_html/bugs/bug.php,v
retrieving revision 1.72
diff -u -r1.72 bug.php
--- bug.php	8 Dec 2004 20:27:18 -0000	1.72
+++ bug.php	15 Dec 2004 19:37:08 -0000
@@ -391,7 +391,7 @@
    <th class="details">Status:</th>
    <td><?php echo htmlspecialchars($bug['status']) ?></td>
    <th class="details">Package:</th>
-   <td><?php echo htmlspecialchars($bug['package_name']) ?></td>
+   <td><a href="/package/<?php echo htmlspecialchars($bug['package_name']) ?>"><?php echo htmlspecialchars($bug['package_name']) ?></a></td>
   </tr>
   <tr id="situation">
    <th class="details">Version:</th>


Expected result:
----------------
The Package header in the bug headers will now be a link to the package's home page on the PEAR web site.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-15 15:00 UTC] helgi at trance dot is
I don't get the point, since straight above we have a link called "Package homepage" which does the same.

Any special reason why you should want that ?
 [2004-12-15 15:01 UTC] aaron dot hawley at uvm dot edu
I just noticed the "Package Home" link next to the other bug links at the top of reports.  My submission still stands as a suggestion for another way to the "Package Home".  It's obviusly not easy to find that link back to the package home page, because when scanning all the links at the top of the page they seem to be related to bug reporting functionality, with "Package Home" thrown in as an after thought.
 [2004-12-15 15:04 UTC] danielc at analysisandsolutions dot com
A link to the package home page is already provided at the top of each bug report.

The patch you provided won't work anyway, because there there are categories for items that aren't packages, such as the website.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 11:01:32 2024 UTC