php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #56218 HTML classes should have screenshots.
Submitted: 2004-10-22 13:09 UTC Modified: 2004-11-14 09:58 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: somekool at gmail dot com Assigned:
Status: Wont fix Package: PECL website (PECL)
PHP Version: 5.0.2 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-10-22 13:09 UTC] somekool at gmail dot com
Description:
------------
some of the class offer by Pear have a static display. 
like QuickForm, DB_DataForm or more especialy DB_Table, I 
think these class should include a screenshot as example, 
so we know what to expect from using it. 
 
If they are customizable, multiple screenshot could be 
shown with tips on how to make them look how we want. 
 
QuickForm seems pretty useless to me so far, since I can't 
split the form fields into two or more different TD/DIV, 
etc. 
 
and I like to give a quick look to DB_Table, without 
spending even 10 mins. from which the screenshots are 
usefull. 
 
 
 
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-24 20:34 UTC] pear-dev at mocsnik dot hu
Screenshots are a good idea.

I just wanted to let you know that you can design your form with QuickForm any way you want. Use some static template renderer.
Sample template:
http://cvs.php.net/co.php/pear/HTML_QuickForm/docs/renderers/templates/it-static.html?r=1.1
Sample script:
http://cvs.php.net/co.php/pear/HTML_QuickForm/docs/renderers/ITStatic_example.php?r=1.4
 [2004-11-14 09:58 UTC] helgi at trance dot is
This is something you should bring up with the package maintainers (via bug report) on the given HTML packages, it's not the job of the web team to provide screenshot and examples for packages.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 00:01:25 2020 UTC