php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56209 Registering account fails with "We could not have said it more clearly..."
Submitted: 2004-10-01 23:06 UTC Modified: 2006-12-26 23:40 UTC
From: stuartl at longlandclan dot hopto dot org Assigned:
Status: Not a bug Package: PECL website (PECL)
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
 [2004-10-01 23:06 UTC] stuartl at longlandclan dot hopto dot org
Description:
------------
I was recently working on an object oriented interface to the GD library, basically a wrapper for the image* functions.

Having got something that was semi-usable, I thought I'd contribute what I had, and hence came here to register an account.

I fill in the form like so:
http://www.longlandclan.hopto.org/~stuartl/pear/pear_register1.png
The passwords match, everything appears fine...

... yet, according to the scripts, apparently not.  Submitting the form yeilds:
http://www.longlandclan.hopto.org/~stuartl/pear/pear_register2.png

I look at the form I submit, and can't see anything physically wrong with it.  Perhaps you could be more explicit as to /what/ the problem is?

Reguards,
Stuart Longland

Reproduce code:
---------------
This is human code, not PHP code:

1. Click Register link on the top navigation bar.
2. Fill in the form.
3. Click Submit Query

Expected result:
----------------
Another page loads saying that either:
(1) The request is under review -- or words to that effect.
(2) A confirmation email has been sent to me@myaddress.net.  Please check your email for further instructions -- or words to that effect.

Or in the case there was a mistake somewhere:
(3) Show me the form, with the faulty field highlighted, so that I may correct it.

Actual result:
--------------
The following message appears above the form:
http://www.longlandclan.hopto.org/~stuartl/pear/pear_register2.png

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-10-02 06:38 UTC] klaus at capitalfocus dot org
The result is expected. Try writing a more detailed description of what you want to do. Something less generic. 

Only thing I can think of at the moment that might not be working properly is if it checks the "filter" checkboxes and immediately rejects the application even if one of the "valid" checkboxes is checked. However, as this issue has not been raised before, I assume what I said above will solve your problem.
 [2004-10-02 06:53 UTC] klaus at capitalfocus dot org
Thank you for taking the time to write to us, but this is not
a bug.

Closing this report. If you still can't get it to work, add a comment to this report. :)
 [2004-10-02 07:23 UTC] stuartl at longlandclan dot hopto dot org
Hi, Thanks for the response,

Okay, where abouts am I expected to write a more detailed description of my intentions?

There are two fields in which I can enter any significant amounts of text... Their corresponding labels are:
"If your intended purpose is not in the list, please state it here"
and
"More relevant information about you (optional)"

The latter one explicitly mentions optional, so it should be okay to leave that blank (besides, that's what my website is for).  The other field, whilst it doesn't say it's optional, the label implies it -- it states, "*IF* your intended purpose is not in the list..."  I simply wanted to contribute a new package -- does that require a full paragraph?

------------------------------------------------------------
On a punt, I just tried again, this time, I didn't check the checkboxes (like I did in the screenshot above).  The submission has gone through.

Is it possible that this "feature" could be disabled?  Okay, I know the page stated you don't need a PEAR account in order to submit patches, use PEAR...etc.  I merely answered the question honestly... Yes, I wish to use PEAR, Yes, I may contribute patches, I certainly wish to learn about PEAR -- I don't need an account for these activities.  But I wish to contribute a new package, for this, I do need an account.

So from where I sit, the form is a little misleading in that reguard.  Again, is it possible for this behaviour to be supressed?  

You could create a few more checkboxes, "Develop and contribute new PEAR packages" and "Help maintain an existing package" for instance, and check for one of those two being checked.  Or better still, abolish the checkboxes altogether, and leave it as just a text box.  That IMHO would reduce the confusion.  Okay, I realise I'm one of the few -- probably the only one to have raised this issue, but what's to suggest someone else hasn't been bitten by this bug?

Thanks for the assistance.
 [2004-10-02 07:38 UTC] klaus at capitalfocus dot org
When submitting a package, you should follow the steps I listed in the following email. Unfortunately you didn't start with step one. :)

http://marc.theaimsgroup.com/?l=pear-dev&m=109411708025545&w=2

As to the registration form itself:

If you had read the page carefully (as you were reminded to do), you would have realized that the checkboxes do not list _any_ legitimate purpose for a pear account. You don't need an account to do any of the things in that list. Leave them blank.

In the first text box, place a description of the package you would like to propose. A link to more information on your package proposal would not hurt. The requests are manually filtered, so it might take some time to get a response.
 [2006-12-26 23:40 UTC] cellog@php.net
bogus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Aug 23 13:01:27 2019 UTC