php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56201 pdflib compile fails
Submitted: 2004-09-26 17:37 UTC Modified: 2015-03-25 21:03 UTC
From: thardiso at bayfed dot com Assigned:
Status: Not a bug Package: pdflib (PECL)
PHP Version: 5CVS-2004-09-26 (dev) OS: Gentoo
Private report: No CVE-ID: None
 [2004-09-26 17:37 UTC] thardiso at bayfed dot com
Description:
------------
Compile on php 5.0.2 fails with: cannot find php_gd.h


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-26 21:17 UTC] thardiso at bayfed dot com
Commenting the line that includes php_gd.h makes the module work correctly. Perhaps changing the test order to check internal first?
 [2004-09-27 15:35 UTC] rjs@php.net
The problem is, that PEAR/PECL does not support packages which use GD, because PHP does not install the Headerfiles needed for GD to /usr/include/php automatically.

So you have to manually copy the GD headerfiles to /usr/include/php and then try again.

Another solution would be to deactiveate the GD related code from pdflib until PHP is able to install these headerfiles.
 [2004-09-27 17:22 UTC] thardiso at bayfed dot com
Thanks, did comment it out and ran a few tests with success. The missing header doesnt seem to actually be used in the code? 

Thanks.

Tyler.
 [2015-03-25 21:03 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-25 21:03 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 10:01:25 2020 UTC