php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56199 iMagick fails to load with Image Magick 6
Submitted: 2004-09-25 13:13 UTC Modified: 2013-12-03 11:37 UTC
From: redoak at nts-online dot net Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.0.0b1 (beta1) OS: Windows XP Pro, SP2
Private report: No CVE-ID: None
 [2004-09-25 13:13 UTC] redoak at nts-online dot net
Description:
------------
I understand support for Image Magick 6 is experimental, but since you asked for failure reports, here you go. 

Server: Apache 2.0.50
PHP: version 5.0.1, running as an ISAPI module
Image Magic Version: ImageMagick-6.0.8-Q16, standard installation for the Windows binary using the MSI installer, all default file paths used.
iMagic version: binary from http://kromann.info/php5/php - Win32, Thread safe - dated 09/25/2004 12:20:01


Upon starting Apache:

Apache.exe - Entry Point Not Found

The procedure entry point DestroyDrawingWand could not be located in the dynamic link library CORE_RL_magick_.dll.


Followed by: 

Warning

PHP Startup: Unable to load dynamic link library 'C:\php-5.0.1-Win32\ext\php_imagick.dll' - The specified procedure could not be found.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-15 09:43 UTC] kubis at pawouk dot net
I have encountered the same problem, after i have restarted the machine, all works well. it seems that imagicks adds a path to PATH environmental variable, so if you try to run apache.exe from commandline it works then, but for running it as service it seems you have to restart the machine.
 [2004-12-15 10:26 UTC] kubis at pawouk dot net
Well, forget my post :). I was using ImageMagick 5, not 6. With imagemagick 6 it doesnt work; i get the same error
 [2013-12-03 11:37 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2013-12-03 11:37 UTC] mike@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC