php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56197 Does not work with GraphicsMagick 1.1.3
Submitted: 2004-09-24 09:30 UTC Modified: 2013-12-03 13:02 UTC
From: k at ailis dot de Assigned: mkoppanen (profile)
Status: Not a bug Package: imagick (PECL)
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2004-09-24 09:30 UTC] k at ailis dot de
Description:
------------
It looks like the newest GraphicsMagick (currently 1.1.3) also has a "Wand" (whatever this means"). There is a libGraphicsMagickWand library installed by GraphicsMagick but the imagick extension uses this Wand only if ImageMagick > 6.0.0 was detected. Therfor I'm not able to compile imagick. I get undefined references to DrawAllocateWand and  DestroyDrawingWand. 
I think adding a check for GraphicsMagick 1.1.3 will fix this problem. But I don't know how to do this myself,  I hate this autoconf stuff ;-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-25 17:17 UTC] k at ailis dot de
Here is a patch to solve the problem. It checks for GraphicsMagick 1.1.3 or higher and then does the same as for ImageMagick 6.0.0:

diff -Nur imagick.orig/config.m4 imagick/config.m4
--- imagick.orig/config.m4  2004-06-28 15:16:15.000000000 +0200
+++ imagick/config.m4   2004-09-25 19:23:34.000000000 +0200
@@ -97,7 +97,11 @@
     AC_MSG_RESULT(yes. Adding compatibility options)
     AC_DEFINE(IMAGICK_NEEDS_WAND,1,[ ])
     PHP_ADD_LIBRARY_WITH_PATH(Wand, $IMAGEMAGICK_DIR/lib, IMAGICK_SHARED_LIBADD)
-  else
+  elif test "$imagemagick_version" -ge 1001003 && test "$MAGICK_NAME" == "GraphicsMagick"; then
+    AC_MSG_RESULT(yes. Adding compatibility options for GraphicsMagick)
+    AC_DEFINE(IMAGICK_NEEDS_WAND,1,[ ])
+    PHP_ADD_LIBRARY_WITH_PATH(GraphicsMagickWand, $IMAGEMAGICK_DIR/lib, IMAGICK_SHARED_LIBADD)
+  else
     AC_MSG_RESULT(no)
   fi
   PHP_EXTENSION(imagick, $ext_shared)
 [2012-07-20 02:43 UTC] zsbe17fr at yahoo dot fr
There's something similar on windows too :

If enabling both imagick & gmagick extensions (by downloading the devel pack & running phpize / compiling), the imagick extension returns NO supported formats, and possibly some codec errors.
It also had some errors about missing/common modules.
 [2013-12-03 11:36 UTC] mike@php.net
-Assigned To: +Assigned To: mkoppanen
 [2013-12-03 13:02 UTC] mkoppanen@php.net
-Status: Assigned +Status: Not a bug
 [2013-12-03 13:02 UTC] mkoppanen@php.net
Expired issue
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC