php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56166 Can't compile mono on FC2 Apache/2.0.50 PHP 5.0.1
Submitted: 2004-08-13 04:14 UTC Modified: 2015-03-23 20:08 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pecl_bugs at marfix dot net Assigned:
Status: Not a bug Package: mono (PECL)
PHP Version: 5CVS-2004-08-13 (dev) OS: Linux 2.6 ( Fedora Core 2 )
Private report: No CVE-ID: None
 [2004-08-13 04:14 UTC] pecl_bugs at marfix dot net
Description:
------------
Since ( 3 Months ago ) I try to install the mono extension I did have every time the same Error. And I realy don't no where the problem is, is it eh bug? 

Reproduce code:
---------------
phpize
./configure --with-mono
make

Expected result:
----------------
after i executed 'make':
/bin/sh /home/marfix/SRC/web/PHP/PECL/mono-0.7/libtool --mode=compile gcc  -I. -I/home/marfix/SRC/web/PHP/PECL/mono-0.7 -DPHP_ATOM_INC -I/home/marfix/SRC/web/PHP/PECL/mono-0.7/include -I/home/marfix/SRC/web/PHP/PECL/mono-0.7/main -I/home/marfix/SRC/web/PHP/PECL/mono-0.7 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  -DHAVE_CONFIG_H  -g -O2  -prefer-pic -c /home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c -o php_mono.lo
 gcc -I. -I/home/marfix/SRC/web/PHP/PECL/mono-0.7 -DPHP_ATOM_INC -I/home/marfix/SRC/web/PHP/PECL/mono-0.7/include -I/home/marfix/SRC/web/PHP/PECL/mono-0.7/main -I/home/marfix/SRC/web/PHP/PECL/mono-0.7 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DHAVE_CONFIG_H -g -O2 -c /home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c  -fPIC -DPIC -o .libs/php_mono.o
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `create_php_object':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:121: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:122: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `create_mono_object':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:140: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `property_read':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:194: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:200: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `property_write':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:220: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `php_call_mono_method_ex':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:260: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:261: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:266: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:266: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:284: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:292: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `types_match':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:360: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:361: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:362: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `lookup_mono_method_ex':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:391: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:392: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:393: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:395: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `create_signature':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:572: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:574: error: dereferencing pointer to incomplete type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `method_get':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:667: error: structure has no member named `arg_types'
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: At top level:
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:737: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:739: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:740: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:743: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:744: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:746: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:747: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:748: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:749: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:751: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:753: warning: initialization from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `object_new':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:797: warning: passing arg 3 of `zend_objects_store_put' from incompatible pointer type
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:797: error: too few arguments to function `zend_objects_store_put'
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `create_php_method':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:896: error: too few arguments to function `zend_objects_store_put'
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `zif_mono_load':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:984: error: `mono_defaults' undeclared (first use in this function)
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:984: error: (Each undeclared identifier is reported only once
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:984: error: for each function it appears in.)
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c: In function `zm_startup_mono':
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:1039: error: structure has no member named `arg_types'
/home/marfix/SRC/web/PHP/PECL/mono-0.7/php_mono.c:1052: error: structure has no member named `arg_types'
make: *** [php_mono.lo] Fehler 1



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-03-23 20:08 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-23 20:08 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Oct 05 02:03:49 2022 UTC