php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56143 imagick_setfillcolor causes apache child to abort
Submitted: 2004-07-22 17:40 UTC Modified: 2013-12-03 11:38 UTC
From: pecl-imagick at cryp2nite dot nl Assigned:
Status: Not a bug Package: imagick (PECL)
PHP Version: 5.0.0b1 (beta1) OS: linux-i386
Private report: No CVE-ID: None
 [2004-07-22 17:40 UTC] pecl-imagick at cryp2nite dot nl
Description:
------------
I don't have much time to spend on this right now, so I hope this information is enough to be helpful.

If you have any further questions let me know, and I'll make some time to run some more tests if necessary/ helpful. (If you need a backtrace 

Rob


All software below except for the OS is compiled from source.

#############################################################################
# OS
#############################################################################

# uname -a
Linux cc122438-a 2.6.3-4mdk #1 Tue Mar 2 07:26:13 CET 2004 i686 unknown unknown GNU/Linux



#############################################################################
# Apache
#############################################################################

# httpd -V       
Server version: Apache/2.0.50
Server built:   Jul 22 2004 13:37:46
Server's Module Magic Number: 20020903:8
Architecture:   32-bit
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_PROC_PTHREAD_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D HTTPD_ROOT="/opt/pkg"
 -D SUEXEC_BIN="/opt/pkg/bin/suexec"
 -D DEFAULT_PIDLOG="/var/run/httpd.pid"
 -D DEFAULT_SCOREBOARD="/var/run/apache_runtime_status"
 -D DEFAULT_LOCKFILE="/var/run/accept.lock"
 -D DEFAULT_ERRORLOG="/var/log/httpd/error.log"
 -D AP_TYPES_CONFIG_FILE="etc/httpd/mime.types"
 -D SERVER_CONFIG_FILE="etc/httpd/httpd.conf"


#############################################################################
# PHP 
#############################################################################

Version 5.0.0

configure line (according to phpinfo() ):
'./configure' '--with-config-file-path=/opt/pkg/etc/' '--with-regex=system' '--without-mysql' '--without-iconv' '--enable-discard-path' '--enable-force-cgi-redirect' '--enable-memory-limit' '--enable-track-vars' '--disable-posix' '--enable-ipv6' '--enable-xml' '--with-libxml-dir=/opt/pkg' '--with-apxs2=/opt/pkg/sbin/apxs' '--host=i386-mandrake-linux' '--prefix=/opt/pkg' '--without-libiconv-prefix'

N.B.
More modules are installed but don't show up on the configure line due to use of NetBSD pkgsrc.

# ls /opt/pkg/lib/php/
imagick.so  pgsql.so  posix.so


# diff  /opt/pkg/etc/php.ini php.ini-recommended 
295c295
< error_reporting  =  E_ALL & ~E_NOTICE
---
> error_reporting  =  E_ALL
402,403c402
< ;register_argc_argv = Off
< register_argc_argv = On
---
> register_argc_argv = Off
458,459c457
< ;extension_dir = "./"
< extension_dir = "/opt/pkg/lib/php/20040412"
---
> extension_dir = "./"
576d573
< extension=imagick.so
594d590
< extension=pgsql.so

#############################################################################
# ImageMagick
#############################################################################
# identify -version
Version: ImageMagick 5.5.7 03/01/04 Q16 http://www.imagemagick.org
Copyright: Copyright (C) 2003 ImageMagick Studio LLC


#############################################################################
# Error Description
#############################################################################
The error causes my script to exit with no ouput. The executning apache child dies with the following messages in the log:

httpd: pixel_wand.c:842: PixelGetQuantumColor: Assertion `wand->signature == 0xabacadabUL' failed.
[Thu Jul 22 22:54:57 2004] [notice] child pid 4113 exit signal Aborted (6)




Reproduce code:
---------------
Below the offending lines from my code.

This will cause the script to exit with the log message described above.
Commenting out both the setfillcolor line allows the script to finish.
Adding the line back causes the script to fail again.

imagick_begindraw( $tmp_handle );
imagick_setfillcolor( $tmp_handle , '#ffffff');
imagick_setfillopacity( $tmp_handle , 0.8);
imagick_drawrectangle( $tmp_handle,  0, $this->height - 25 , $this->width, $this->height );


Expected result:
----------------
Draw a ractangle on the image

Actual result:
--------------
Apache child exits, no output to browser.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-22 23:24 UTC] pecl-imagick at cryp2nite dot nl
Updated the summary.
I didn't check it properly on submission, sorry.


Rob
 [2004-11-22 14:47 UTC] nospam at linuxdesk dot org
I have exactly the same problem with Imagemagick 6.1.3, Apache 1.3.31, PHP 4.3.9, imagick 0.9.11. Included Examples which use the imagick_setfillcolor (annotate.php) did not work. Is it already fixed in cvs?
 [2013-12-03 11:38 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2013-12-03 11:38 UTC] mike@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC