php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56107 segfault with python.so 0.7.0
Submitted: 2004-06-20 15:51 UTC Modified: 2015-03-23 19:56 UTC
From: christian at freemails dot at Assigned:
Status: Not a bug Package: python (PECL)
PHP Version: unknown OS: Linux 2.6.5
Private report: No CVE-ID: None
 [2004-06-20 15:51 UTC] christian at freemails dot at
Description:
------------
If I load python.so php crashs with a segfault.
This happens with 0.7.0 but not with 0.6.0. (I tried both on my machine but of course I can only guess)

Reproduce code:
---------------
<?php 
dl("python");
phpinfo();
 ?>

Actual result:
--------------
Starting program: /usr/bin/php torrent.php

Program received signal SIGSEGV, Segmentation fault.
0x4137c825 in strtok () from /lib/libc.so.6
(gdb) bt
#0  0x4137c825 in strtok () from /lib/libc.so.6


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-29 12:57 UTC] christian at freemails dot at
well, this was tested with 4.3.7, so I can?t say anything about older releases. Just as note
 [2015-03-23 19:56 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-03-23 19:56 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 16:03:37 2021 UTC