php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #56043 Printer function
Submitted: 2004-04-26 01:26 UTC Modified: 2004-04-27 00:22 UTC
From: nikp at ticino dot com Assigned:
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 4.3.3 OS: Windows2000Server-Windows2000
Private report: No CVE-ID: None
 [2004-04-26 01:26 UTC] nikp at ticino dot com
Description:
------------
Hallo,
I have developed a Intranet php application for the document press on a
local printer, these documents are in a particular format  W=297 x L=1000
milimeter. The problem happens at the moment of the press, the press
maximum is  width of 210 milimeter that is of one A4 standard (210x297
milimeter). I have tried this code with various local printer(plotter,
laser, inkjet...) and various drivers settings but the result is always
the same one, it prints to the maximum 210mm and the rest does not come
printed.
It seems that parameters CUSTOM do not come accepted.
Other documents in A4/A5 format are printed correctly. 
Thanks! 
NIK


Reproduce code:
---------------
...
$handle = printer_open("HPDesignJet500"); //Plotter A0
        printer_set_option($handle, PRINTER_PAPER_FORMAT,
PRINTER_FORMAT_CUSTOM);
        printer_set_option($handle, PRINTER_PAPER_LENGTH, 1000);
        printer_set_option($handle, PRINTER_PAPER_WIDTH,  297);
        printer_start_doc($handle, $this->array_quadro["cod_disegno"] );
        printer_start_page($handle);

ecc ...

Expected result:
----------------
prints document 297x1000 milimeter


Actual result:
--------------
prints document 297x210 milimeter


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-26 02:01 UTC] helgi at trance dot is
And how might this be related to the bug system on pear.php.net ? :)
 [2004-04-27 00:22 UTC] helgi at trance dot is
Sorry, but your problem does not imply a bug in PEAR itself.  For a
list of more appropriate places to ask for help using PEAR, please
visit http://pear.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PEAR.

Try http://bugs.php.net since this is not the right place for reporting a error in the printer_* functions.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 05:03:37 2021 UTC