php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55999 Various site problems
Submitted: 2004-03-09 16:48 UTC Modified: 2004-03-25 13:27 UTC
From: tim dot lokot at printsoft dot com Assigned: mj (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: Win2K
Private report: No CVE-ID: None
 [2004-03-09 16:48 UTC] tim dot lokot at printsoft dot com
Description:
------------
I have noticed the following problems with the PECL site:

. The PECL logo has the text "Pear" as its ALT tag
. This form (the website problem form) requires php version and operating system.  Surely a better selection would be browser and operating system?
. Why ask the user to input a php.ini file, backtrace, reproducible code, expected results, etc when all I'm doing is reporting a problem with the site?
. On submitting the bug report, the close match results seem to be coming from PEAR not PECL. From what I can tell this just seems to be the PEAR site rebranded (60%) as PECL.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-09 16:55 UTC] toby@php.net
OS and PHP version make much sense for package related bugs. The website is just a special case. For that, you can set both to "irrelevant". If you have browser related issues, please note the browser version inside the bug report.

Same for backtrace, etc. Leave them blank if not neccessary. Reproduction code can be obtained from cvs: http://cvs.php.net/cvs.php/pearweb or peclweb and expected result seems to look good for me.

Since PECL and PEAR bugsystem is the same thing, the close match results come from both.
 [2004-03-09 17:14 UTC] tim dot lokot at printsoft dot com
I understand that I can leave those fields out or mark them as irrelevant, just seems a little counter intuitive that's all.

Particularly with the effort that seems to be going around to increase the use of PECL, it's weird submitting a bug in PECL and editing it in PEAR.  Also having PEAR results returned from a PECL search.  Even the link that I clicked on in my email referenced PEAR and not PECL.  Doesn't this PEAR/PECL are one and the same just coinfuse the issue when trying to create brand awareness for PECL?  It already has the stigma of Siberia attached to it.

Anyway, regardless of all that, the ALT tag on the PECL page header is wrong
 [2004-03-25 13:27 UTC] mj@php.net
The alternative text for the PECL logo has been adjusted.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 02:01:23 2021 UTC