php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55990 Package stats: Changing to other package not possible
Submitted: 2004-02-17 06:35 UTC Modified: 2006-12-26 22:49 UTC
From: pear dot neufeind at speedpartner dot de Assigned: danielc (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2004-02-17 06:35 UTC] pear dot neufeind at speedpartner dot de
Description:
------------
If you selected a package on the package statistic-package it's not possible to move to any other package. It's also not possible to move back to a more generalized category.

Reproduce code:
---------------
- go to:
http://pear.php.net/package-stats.php?cid=12&pid=237&rid=&submit=Go
This links puts you in "Images > Image_Graph" (just for example).

- Try selecting Image_GIS from the dropdown. It shows you the bar-graph for Image_GIS, but it doesn't show the "release statistics" properly.

- Try selecting top-category "networking": You will not get any package-stats as you would if you selected "networking" right after entering the package stats page all from the beginning.

Expected result:
----------------
see Reproduce code

Actual result:
--------------
see Reproduce code

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-16 17:53 UTC] helgi at trance dot is
could you confirm that this is still a issue ? Seems to me that this isn't a issue anymore.
 [2004-05-16 18:13 UTC] pear dot neufeind at speedpartner dot de
I still experienced problems. I was able to choose a category (e.g. HTTP), then choose a package (e.g. HTTP_Header) and then move to another package (e.g. HTTP_Download). The package-dropdown changed as expected. But if you select a release and then change back to e.g. HTTP_Header the download-statistics are gone - although the version-dropdown shows "select a release" and should default to including all releases in the stats.
But a more grave bug occurs if you now change the category to "Caching". It still shows the release-dropdown, still shows stats for HTTP_Header though general category-stats should be shown.

Now let's start the walkthrough again from scratch. Choose category HTTP. Category-stats are shown. Choose category Caching. No stats are shown anymore.

PS: Tested with Opera 7.50. But I don't think it matters in this case.
 [2004-05-16 18:21 UTC] helgi at trance dot is
ahh true still problems :)
 [2004-06-09 19:00 UTC] klaus at capitalfocus dot org
I'm not sure this hasn't been fixed. It works fine for me in IE and Firefox...
 [2004-06-09 19:48 UTC] pear dot neufeind at speedpartner dot de
Klaus, are you sure you did "exactly" what I described in last bug-explanation? I'm still able to reproduce it on IE 5.5 and Opera 7.50 here.
 [2004-08-10 14:51 UTC] klaus at capitalfocus dot org
Figured out what the problem is. The querystring was misformed for some reason. This is what it is supposed to look like:

http://pear.php.net/package-stats.php?cid=10&pid=233&rid=Select%20release%20...

This is what it actually looks like:

http://pear.php.net/package-stats.php?cid=10&pid=233&rid=Select%20release%20...

Basically, the ampersand (&) was manually htmlencoded so it becomes &

This happens because of the javascript in package-stats.php. Editing lines 36 and 38 in CVS to change & > & would solve the problem.
 [2004-08-10 16:12 UTC] danielc at analysisandsolutions dot com
Fixed in CVS.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 17 04:01:23 2021 UTC