php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55895 Installer crashes on list-all (Undefined index: radius)
Submitted: 2003-10-16 11:37 UTC Modified: 2003-12-11 08:18 UTC
From: ths at 4bconsult dot de Assigned: pajoye (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: 4.3.3 OS: WinXP
Private report: No CVE-ID: None
 [2003-10-16 11:37 UTC] ths at 4bconsult dot de
Description:
------------
pear-database.php:543: Notice: Undefined index: radius

This is maybe the same Problem as described in:
http://pear.php.net/bugs/bug.php?id=74

But occours in all states.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-16 14:40 UTC] pajoye@php.net
Hello,

The different methods of pear-database on pearweb require an optionnal argument to filter or not pecl packages.

If the methods has been called from a RPC request, all packages should be returned/selected.

I think this problem is the same as the many reports posted today on pear-dev.

I will try to fix asap or martin do you have the time to dig in?

pierre
 [2003-10-16 15:17 UTC] mj@php.net
Can the original reporter please give some hints on how to reproduce the problem? Otherwise I can't fix anything.
 [2003-10-16 15:19 UTC] mj@php.net
Never mind -- I just saw that it is related to list-all. However that works for me:

# pear list-all | grep radius
radius                  1.2.2


 [2003-10-16 16:01 UTC] mj@php.net
This has been fixed in CVS. The changes will be online as soon as the webpage gets updated.

If there are more problems related to the PEAR/PECL split, please re-open this report.
 [2003-10-16 16:22 UTC] pajoye@php.net
It is indeed still open.

And nothing is fixed yet in cvs. That requires to add conditionnal where clause  "p.package_type='pear'" as done in package::info.

pierre
 [2003-10-16 19:34 UTC] mroch@php.net
It works for me now, but I get "Undefined variable: proxy_host in Remote.php on line 237 [& 250]".  Pierre said he fixed this in CVS on pear-dev today, so I look forward to a bugfix release soon. :)
 [2003-10-16 20:09 UTC] pajoye@php.net
Marshall

Please try (as root in your case ;) ):
# pear clear-cache
# pear -vvv list-all

the bug should be back

pierre
 [2003-10-16 20:57 UTC] mroch@php.net
Pierre is right, it is still a bug, but only if preferred_state = beta (and maybe others?).  With "stable," it seems to work.
 [2003-10-17 08:25 UTC] mj@php.net
Then someone else should probably fix that. I have neither time nor interest to fix bugs that I cannot reproduce properly.
 [2003-11-17 21:13 UTC] mroch@php.net
I think this is fixed.  Can Pierre or Martin please confirm?
 [2003-12-11 08:18 UTC] pajoye@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pear.php.net.

In case this was a pear.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PEAR better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Oct 21 16:01:24 2020 UTC