php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55838 SolrClient::addDocument does not throw an exception
Submitted: 2011-10-03 16:37 UTC Modified: 2015-11-04 23:27 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: mauricio at youzee dot com Assigned: omars (profile)
Status: Closed Package: solr (PECL)
PHP Version: 5.3.8 OS: N/A
Private report: No CVE-ID: None
 [2011-10-03 16:37 UTC] mauricio at youzee dot com
Description:
------------
---
From manual page: http://www.php.net/solrclient.adddocument#refsect1-
solrclient.adddocument-returnvalues
---
http://www.php.net/manual/en/solrclient.adddocument.php
It should throw an exception when Solr host is not available, and it is 
triggering an error WARNING level.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2014-03-20 12:42 UTC] omars@php.net
-Package: Unknown/Other Function +Package: solr
 [2015-11-04 23:24 UTC] omars@php.net
-Assigned To: +Assigned To: omars
 [2015-11-04 23:26 UTC] omars@php.net
-Status: Assigned +Status: Closed
 [2015-11-04 23:26 UTC] omars@php.net
resolved since 1.1.0, 2.0.0.

It throws an exception now
 [2015-11-04 23:27 UTC] omars@php.net
-Type: Documentation Problem +Type: Bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 16:03:36 2021 UTC