php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55769 Make Fails with "Missing Separator" error
Submitted: 2011-09-23 17:57 UTC Modified: 2011-09-24 19:16 UTC
From: brad at hostland dot com Assigned: aharvey
Status: Closed Package: Compile Failure
PHP Version: 5.4.0beta1 OS: Linux 2.6.18-238.19.1.el5xen
Private report: No CVE-ID:
 [2011-09-23 17:57 UTC] brad at hostland dot com
Description:
------------
When I execute the configure command, it works fine and I get the "Thank you for using PHP" message. I'm using the following configure options:

./configure '--prefix=/usr/local/lsws/lsphp5' '--with-mysqli=mysqlnd' '--with-mysql=mysqlnd' '--with-zlib' '--with-gd' '--with-freetype-dir' '--enable-gd-native-ttf' '--with-jpeg-dir' '--enable-shmop' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-mbstring' '--with-iconv' '--with-curl' '--with-openssl' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-litespeed' '--with-libdir=/lib64' '--with-mcrypt' '--with-xmlrpc' '--with-tidy' '--enable-soap'

Then, I execute make and I get:

Makefile:267: *** missing separator.  Stop.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-24 08:15 UTC] rasmus@php.net
-Status: Open +Status: Feedback
 [2011-09-24 08:15 UTC] rasmus@php.net
Could you show us lines 260-270 (with line numbers please) of the Makefile that 
was generated?
 [2011-09-24 08:34 UTC] brad at hostland dot com
-Status: Feedback +Status: Open
 [2011-09-24 08:34 UTC] brad at hostland dot com
Here are lines 260 - 270 of the Makefile:

260:litespeed: $(SAPI_LITESPEED_PATH)
261:
262:$(SAPI_LITESPEED_PATH): $(PHP_GLOBAL_OBJS) $(PHP_BINARY_OBJS) $(PHP_LITESPEED_OBJS)
263:	$(BUILD_LITESPEED)
264:
265:install-litespeed: $(SAPI_LITESPEED_PATH)
266:	@echo "Installing PHP LitSpeed binary:   $(INSTALL_ROOT)$(bindir)/"
267:    @$(INSTALL) -m 0755 $(SAPI_LITESPEED_PATH) $(INSTALL_ROOT)$(bindir)/lsphp
268:
269:cgi: $(SAPI_CGI_PATH)
270:

I noticed line 267 had four spaces instead of a tab. I replaced the four spaces with a tab and now it works.
 [2011-09-24 19:13 UTC] aharvey@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: aharvey
 [2011-09-24 19:16 UTC] aharvey@php.net
Automatic comment from SVN on behalf of aharvey
Revision: http://svn.php.net/viewvc/?view=revision&revision=317251
Log: Fix bug #55769 (Make Fails with "Missing Separator" error) via s/    /^I/.
 [2011-09-24 19:16 UTC] aharvey@php.net
-Status: Assigned +Status: Closed
 [2011-09-24 19:16 UTC] aharvey@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2012-04-18 09:48 UTC] laruence@php.net
Automatic comment on behalf of aharvey
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f75c7302cb5304bbf87b9dfe9e3969a5d3042a50
Log: Fix bug #55769 (Make Fails with "Missing Separator" error) via s/    /^I/.
 [2012-07-24 23:39 UTC] rasmus@php.net
Automatic comment on behalf of aharvey
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f75c7302cb5304bbf87b9dfe9e3969a5d3042a50
Log: Fix bug #55769 (Make Fails with "Missing Separator" error) via s/    /^I/.
 [2013-11-17 09:36 UTC] laruence@php.net
Automatic comment on behalf of aharvey
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f75c7302cb5304bbf87b9dfe9e3969a5d3042a50
Log: Fix bug #55769 (Make Fails with "Missing Separator" error) via s/    /^I/.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 04:02:11 2014 UTC