php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55759 mem leak when use built-in server
Submitted: 2011-09-22 03:01 UTC Modified: 2011-11-15 03:16 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: laruence@php.net Assigned: laruence
Status: Closed Package: Built-in web server
PHP Version: 5.4.0beta1 OS:
Private report: No CVE-ID:
 [2011-09-22 03:01 UTC] laruence@php.net
Description:
------------
router.php
<?php
  return FALSE;
?>

a.php
<?php
echo "llllll"
?>

./php -S**** -t .  router.php

then request  http://*****/a.php

Expected result:
----------------
111111

Actual result:
--------------
[Thu Sep 22 10:55:32 2011] 172.21.232.67:50662 [200]: /a.php
[Thu Sep 22 10:55:32 2011]  Script:  '-'
php-src/trunk/main/output.c(803) :  Freeing 0x2A95DDB200 (88 bytes), script=-
php-src/trunk/Zend/zend_alloc.c(2529) : Actual location (location was relayed)
[Thu Sep 22 10:55:32 2011]  Script:  '-'
php-src/trunk/main/output.c(804) :  Freeing 0x2A95DDB2B0 (23 bytes), script=-
[Thu Sep 22 10:55:32 2011]  Script:  '-'
php-src/trunk/main/output.c(809) :  Freeing 0x2A95DDB320 (8192 bytes), script=-
[Thu Sep 22 10:55:32 2011]  Script:  '-'
php-src/trunk/Zend/zend_stack.c(37) :  Freeing 0x2A95DDD378 (512 bytes), script=-
[Thu Sep 22 10:55:32 2011]  Script:  '-'
php-src/trunk/Zend/zend_stack.c(42) :  Freeing 0x2A95DDD5D0 (8 bytes), script=-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-25 17:08 UTC] felipe@php.net
I can't reproduce it.
 [2011-10-31 10:48 UTC] fa@php.net
Cannot reproduce on Debian testing with neither beta1 nor beta2
 [2011-11-13 13:13 UTC] dsp@php.net
-Assigned To: +Assigned To: moriyoshi
 [2011-11-15 03:15 UTC] laruence@php.net
Automatic comment from SVN on behalf of laruence
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=319224
Log: Fixed bug #60159 (Router returns false, but POST is not passed to requested
resource) and bug #55759 (mem leak when use built-in server)
 [2011-11-15 03:16 UTC] laruence@php.net
-Status: Assigned +Status: Closed -Assigned To: moriyoshi +Assigned To: laruence
 [2011-11-15 03:16 UTC] laruence@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2012-04-18 09:47 UTC] laruence@php.net
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f8503b4332dd27d2e60147e318212f9f6c39c3ce
Log: Fixed bug #60159 (Router returns false, but POST is not passed to requested resource) and bug #55759 (mem leak when use built-in server)
 [2012-07-24 23:38 UTC] rasmus@php.net
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f8503b4332dd27d2e60147e318212f9f6c39c3ce
Log: Fixed bug #60159 (Router returns false, but POST is not passed to requested resource) and bug #55759 (mem leak when use built-in server)
 [2013-11-17 09:35 UTC] laruence@php.net
Automatic comment on behalf of laruence
Revision: http://git.php.net/?p=php-src.git;a=commit;h=f8503b4332dd27d2e60147e318212f9f6c39c3ce
Log: Fixed bug #60159 (Router returns false, but POST is not passed to requested resource) and bug #55759 (mem leak when use built-in server)
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC