php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55751 printf issue in combinatin with com connection
Submitted: 2011-09-21 08:25 UTC Modified: 2011-09-21 10:31 UTC
From: michael dot fellinger at multitec-sono dot at Assigned:
Status: Not a bug Package: COM related
PHP Version: Irrelevant OS: Windows 7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: michael dot fellinger at multitec-sono dot at
New email:
PHP Version: OS:

 

 [2011-09-21 08:25 UTC] michael dot fellinger at multitec-sono dot at
Description:
------------
I use PHP Version 5.3.5 but it seems to be not solved in newer Versions

It only happends with the number or string 1900 and only if the execute command from the adodb connection was performed.
I gues i also happens with other numbers.

Test script:
---------------
$ADODB = new COM( 'ADODB.Connection' );
$ADODB->open($strConn);                      #connection to a MS-Access Database

$RS = $ADODB->execute("SELECT Lagerwert FROM tblStammdaten WHERE tblStammdaten.Seriennummer='74925KR9';");
echo $RS->Fields(0)->Value . "<br>";
$x = sprintf("%f",$RS->Fields(0)->Value);
echo $x;


Expected result:
----------------
1900
1900.000000

Actual result:
--------------
1900
18:0.000000 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-21 08:42 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2011-09-21 08:42 UTC] pajoye@php.net
Please try with 5.3.8 or a snapshot.
 [2011-09-21 10:29 UTC] michael dot fellinger at multitec-sono dot at
5.3.8 solves the problem, thanks!
 [2011-09-21 10:31 UTC] pajoye@php.net
-Status: Feedback +Status: Bogus
 [2011-09-21 10:31 UTC] pajoye@php.net
old vc6 issue > bogus.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 06:05:52 2022 UTC