php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55734 date - Microseconds problem
Submitted: 2011-09-20 07:55 UTC Modified: 2011-09-24 20:06 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bugzilla33 at gmail dot com Assigned:
Status: Duplicate Package: Date/time related
PHP Version: 5.4.0beta1 OS: All
Private report: No CVE-ID: None
 [2011-09-20 07:55 UTC] bugzilla33 at gmail dot com
Description:
------------
Specification:

u - Microseconds (added in PHP 5.2.2) - Example: 654321

Test script:
---------------
<?=date('u')?>

Expected result:
----------------
Example: 654321

Actual result:
--------------
000000

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-24 20:06 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 [2011-09-24 20:06 UTC] aharvey@php.net
Duplicate of a bunch of bugs, including bug #41806.

In short, date() only deals with integer timestamps, so the number of
microseconds is always 0.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC