php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #55727 parse_ini_file: discrepance between documentation and example
Submitted: 2011-09-19 14:17 UTC Modified: 2015-04-17 14:42 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: technik at thomas-heuer dot eu Assigned: salathe (profile)
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS: *
Private report: No CVE-ID: None
 [2011-09-19 14:17 UTC] technik at thomas-heuer dot eu
Description:
------------
Regarding the documentation for parse_ini_file:
http://php.net/manual/en/function.parse-ini-file.php#refsect1-function.parse-ini-file-notes

Under notes it is stated, that the »characters ?{}|&~![()^" must not be used anywhere in the key […]« but above, there is an example using the square brackets for arrays within the .ini-files, which works also perfectly under current PHP-versions. The notes should be cleaned.

(Also, it seems some other features, regarding arrays in .ini-files are not documented as well. See for example: http://stackoverflow.com/questions/338537/can-an-array-be-specified-in-an-ini-file-to-be-parsed-using-zend-config-ini/339135#339135)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-11-15 11:50 UTC] mgriffiths at gmail dot com
Doc edit has been submitted for review which removes the '[' character from the 
notes, as it is allowed in the key.

Second issue should be launched as a separate bug.
 [2015-04-17 14:14 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=336561
Log: Add some ini keys (doc bug #55727)

--
Patch by Pasindu (ppasindud@gmail.com)
 [2015-04-17 14:42 UTC] salathe@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: salathe
 [2015-04-17 14:42 UTC] salathe@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 12:01:28 2024 UTC