|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55689 Make install fails looks for in <apache2>/modules, doesn't find.
Submitted: 2011-09-14 04:01 UTC Modified: -
Avg. Score:3.5 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: kompella dot kamesh at gmail dot com Assigned:
Status: Open Package: Apache2 related
PHP Version: 5.3.8 OS: Ubuntu 64 bit
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-09-14 04:01 UTC] kompella dot kamesh at gmail dot com
Machine: Linux 2.6.32-33-generic #72-Ubuntu SMP.

"Make install" looks for under the modules folder in apache 
installation. Specifically, it fails at this step:

chmod 755 /usr/local/apache2/modules/

I tried the same steps with 5.2.17 and verified the problem does not occur. This 
looks like a regression.

In both cases, I ran "make install" with sudo.

Test script:
1. ./configure --prefix=/usr/local/apache2/php --with-apxs2=/usr/local/apache2/bin/apxs --disable-cgi --with-config-file-path=/usr/local/apache2/php --with-openssl --with-kerberos --with-zlib --with-bz2 --with-curl --enable-dba --with-gd --with-xsl --with-mysql --with-gettext --with-regex=system --with-pgsql=shared --enable-shared=true --enable-dbase --disable-static

2. make
3. sudo make install


Add a Patch

Pull Requests

Add a Pull Request

PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 08:01:24 2020 UTC