php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55661 mysqli/tests/bug54674.phpt failed when link against libmysql
Submitted: 2011-09-10 04:07 UTC Modified: 2011-09-12 11:35 UTC
From: laruence@php.net Assigned: mysql (profile)
Status: Not a bug Package: MySQLi related
PHP Version: trunk-SVN-2011-09-10 (SVN) OS: Linux
Private report: No CVE-ID: None
 [2011-09-10 04:07 UTC] laruence@php.net
Description:
------------
mysqli/tests/bug54674.phpt failed when linked against libmysql


Test script:
---------------
none

Expected result:
----------------
PASS

Actual result:
--------------
FAIELD
diff:
001+ bool(false)
001- bool(true)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-10 04:41 UTC] laruence@php.net
ext/mysqli/tests/mysqli_last_insert_id.phpt also failed, with diff:
002+ [007] API id should have been reset to 0 because previous query was SELECT, 
got API 1, SQL 1
003+ [010] API id should have been reset to 0 because previous query was SELECT, 
got API 1, SQL 1
008+ [027] API id should have been reset to 0 because previous query failed, got 
API 4, SQL 4
 [2011-09-10 12:09 UTC] laruence@php.net
-Assigned To: +Assigned To: mysql
 [2011-09-12 11:35 UTC] andrey@php.net
-Status: Assigned +Status: Bogus
 [2011-09-12 11:35 UTC] andrey@php.net
This is a bug in libmysql, which does things which contradict with the documentation.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 16 06:05:46 2022 UTC