php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5561 include()
Submitted: 2000-07-13 16:26 UTC Modified: 2000-08-08 23:02 UTC
From: freax at pandora dot be Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: freax at pandora dot be
New email:
PHP Version: OS:

 

 [2000-07-13 16:26 UTC] freax at pandora dot be
This one crashed my box ..
or at least made it unavailable for may hours (at least five hours)
(= no more way to connect to for example ssh,telnet,apache)
 
> --filename: documentroot/ index.php---
> <?
>         include($file);
> ?>

I'm tempted to say "Don't do that." :-)

I guess you should file a bug report, though, since whatever it does, it
shouldn't crash your box...

http://bugs.php.net/


--> so I did :) <--

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-14 02:04 UTC] joey at cvs dot php dot net
Can you povide a backtrace or something? I was
unable to reproduce this...
Tried:
Apache module on Linux and Solaris 2.6
CGI on Linux and Solaris 2.6

It's possible any of these were later than 4.0.1 pl2.
Either way, a backtrace would go a long ways.

Please read the Bug do's and dont's


 [2000-08-08 23:02 UTC] waldschrott@php.net
Closed due to missing user feedback.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 13:05:54 2022 UTC