php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #55499 404 links in the docs
Submitted: 2011-08-24 14:35 UTC Modified: 2015-05-18 02:08 UTC
Votes:6
Avg. Score:4.0 ± 1.0
Reproduced:2 of 3 (66.7%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: hannes dot magnusson at gmail dot com Assigned: pajoye
Status: Re-Opened Package: *General Issues
PHP Version: Irrelevant OS: *
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-08-24 14:35 UTC] hannes dot magnusson at gmail dot com
Description:
------------
The following entities are pointing to now moved/removed information from the 
docs

&url.win32.build-libs; : http://pecl2.php.net/downloads/php-windows-builds/php-
libs/
&url.win32.binary-tools; : http://pecl2.php.net/downloads/php-windows-
builds/php-libs/binary-tools.zip
&url.pecl.timezonedb.dll; : http://pecl4win.php.net/ext.php/php_timezonedb.dll
&url.pecl.win.ext; : http://pecl4win.php.net/ext.php/
&url.pecl.get.win.php5.0; : http://snaps.php.net/win32/PECL_5_0/
&url.pecl.get.win.php4.3; : http://snaps.php.net/win32/PECL_4_3/
&url.pecl.get.win; : http://snaps.php.net/win32/PECL_STABLE/
&url.pecl.get.win.unstable; : http://snaps.php.net/win32/PECL_UNSTABLE/
&url.jpeg; : http://pecl2.php.net/downloads/php-windows-builds/source/

I believe most of them just have new urls, but don't know which :)

Test script:
---------------
http://svn.php.net/repository/phpdoc/doc-base/trunk/entities/global.ent

Expected result:
----------------
Updated urls


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-24 14:35 UTC] bjori@php.net
-Assigned To: +Assigned To: pajoye
 [2011-11-24 11:37 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&revision=319748
Log: point &url.jpeg; to IJG website (doc #55499)
 [2011-11-24 11:38 UTC] salathe@php.net
-Status: Assigned +Status: Closed
 [2011-11-24 11:38 UTC] salathe@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2011-11-24 11:39 UTC] salathe@php.net
Oops, wrong quick-fix message! Here's the right one.

This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2011-11-24 12:09 UTC] bjori@php.net
All the other pecl entities are still br0ken. Only the jpeg one was fixed by that 
commit
 [2011-11-24 12:09 UTC] bjori@php.net
-Status: Closed +Status: Re-Opened
 [2011-11-24 12:12 UTC] pajoye@php.net
for 4.x and 5.2, drop them, we don't support them.

For 5.3/4, there is the SDK which contains all (oss) libs required to build PHP.

For pecl extensions, we are not there yet but that should point to the project 
page as far as I can tell, for what Salathe asked me, the project URL, not the 
builds we provide for windows builds.

Or in short: this bug covers many not necessary related issues, pls split it for 
clarity.
 [2011-11-24 12:13 UTC] pajoye@php.net
-Assigned To: pajoye +Assigned To: johannes
 [2011-11-24 12:13 UTC] pajoye@php.net
-Assigned To: johannes +Assigned To: bjori
 [2012-04-06 17:24 UTC] bjori@php.net
I have no idea why this was assigned to me.
I don't know the correct URLs at all, which is why I created the ticket.
 [2012-04-06 17:24 UTC] bjori@php.net
-Assigned To: bjori +Assigned To: pajoye
 [2012-04-06 17:26 UTC] bjori@php.net
"Or in short: this bug covers many not necessary related issues, pls split it for 
clarity."

No.. this bug is about existing documentation pages that uses these links.
If these items no longer exist or the docs are outdated, then please tell us 
which pages should be removed
 [2015-05-18 02:08 UTC] cmb@php.net
Of the mentioned entities only &url.pecl.win.ext; and &url.jpeg; are still used in the English manual. So basically, they could be removed, but that might break translations. Not sure, what's the usual procedure to get rid of entities.

&url.jpeg; points to http://www.ijg.org/, what seems to be fine, as this is not Windows specific.

With regard to &url.pecl.win.ext; it appears to be best to remove its usages from the manual. It's only used to link to the judy and yaml extensions (and in an out-commented section to link to sdo), for which there are DLLs linked on the PECL project page.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC