php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55498 filename bug
Submitted: 2011-08-24 08:09 UTC Modified: 2013-02-18 00:35 UTC
From: time2t at naver dot com Assigned:
Status: No Feedback Package: Built-in web server
PHP Version: 5.4.0alpha3 OS: windows
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-08-24 08:09 UTC] time2t at naver dot com
Description:
------------
<html>
<head>
</head>
<body>
<form name=fboardform method=post action="?" enctype="multipart/form-data">
<input type=text class=ed name=bo_subject size=60 maxlength=120 value=''>
<br />
<select name='gr_id'>
<option value='asas'>asas</option>
</select><br />
<input type=file name="bo_image_head" class=ed size=60><br />
<input type=submit class=btn1 accesskey='s' value='  submit  '>
</form>

<?
print_r($_FILES);
?>
</body>
</html>

-----------------------------
POST file name test.msi
-----------------------------
Array
(
    [bo_image_head] => Array
        (
            [name] => est.msi
            [type] => application/octet-stream
            [tmp_name] => D:\server\tmp\php711.tmp
            [error] => 0
            [size] => 664576
        )

)


-----------------------------

[name] => est.msi <-- test.msi bug

original file name test.msi ??

Test script:
---------------
-----------------------------
POST file name test.msi
-----------------------------
Array
(
    [bo_image_head] => Array
        (
            [name] => est.msi
            [type] => application/octet-stream
            [tmp_name] => D:\server\tmp\php711.tmp
            [error] => 0
            [size] => 664576
        )

)


-----------------------------

[name] => est.msi <-- test.msi bug

original file name test.msi ??


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-24 09:59 UTC] laruence@php.net
-PHP Version: 5.3.8 +PHP Version: 5.4.0alpha3
 [2011-08-24 09:59 UTC] laruence@php.net
I don't think 5.3.8 has webserver built-in, should be 5.4.0
and this is dup to #55484(since this report is more clearly, I will mark 55484 
as dup).

at last I can't reproduce this in Linux with php-5.4.0-trunk, can you try with 
the snapshot

For Windows:

  http://windows.php.net/snapshots/
 [2011-08-24 09:59 UTC] laruence@php.net
-Status: Open +Status: Feedback
 [2013-02-18 00:35 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 12:01:24 2020 UTC