php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55204 ICONV iconv_strlen() causing apache to crash/segmentation fault(11)
Submitted: 2011-07-14 03:48 UTC Modified: 2013-09-08 09:08 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:2 (66.7%)
From: michel02 at hotmail dot com Assigned:
Status: Closed Package: ICONV related
PHP Version: 5.3.6 OS: Solaris 10
Private report: No CVE-ID: None
 [2011-07-14 03:48 UTC] michel02 at hotmail dot com
Description:
------------
After successfully compiling PHP 5.3.6 on (patched) Solaris 10 with all required GNU packages from sunfreeware.com, iconv_strlen($var) causes Apache2 extension to crash. Only error apache shows is [notice] child pid 34232 exit signal Segmentation fault (11). No output to browser was generated.

configure command for compiling PHP was:

./configure --verbose --with-gnu-ld --prefix=/usr/local/php --without-gd --disable-pdo --without-pdo-sqlite --without-sqlite --with-config-file-path=/usr/local/php/lib --with-oci8=/export/home/oracle/product/11.1.0/pweb --with-apxs2=/usr/local/apache2/bin/apxs --enable-bcmath --with-openssl=/usr/local/ssl --with-ldap=/usr/local --with-bz2 --enable-calendar --enable-ctype --with-curl=/usr/local/curl --with-curlwrappers  --enable-exif --enable-ftp --with-zlib=/usr/local --with-gettext --with-gmp --enable-hash --enable-json --enable-mbstring --enable-mbregex --enable-pcntl --with-libedit=no --with-readline --enable-session --enable-shmop --enable-simplexml --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-tokenizer --enable-wddx --with-libexpat-dir=/usr/local --enable-xml --enable-xmlreader --with-xmlrpc --enable-xmlwriter --with-xsl --enable-zip --disable-static --enable-pcntl --enable-magic-quotes --with-pcre-dir=/usr/local --with-pcre-regex --with-pear


Test script:
---------------
print iconv_strlen("test","UTF-8");

Expected result:
----------------
generate some output

Actual result:
--------------
apache thread killed, error [notice] child pid 34232 exit signal Segmentation fault (11) in errorlog and no output for browser.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-15 17:42 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2011-07-15 17:42 UTC] felipe@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2012-06-21 14:44 UTC] gabriel dot rota at gmail dot com
this LD_PRELOAD fixed my issue

export LD_PRELOAD=/usr/local/lib/preloadable_libiconv.so
 [2013-02-18 00:34 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 [2013-08-25 22:04 UTC] skrueger at europe dot com
I see the same error on Solaris 11.1:

root@www:/tmp# /usr/php/5.3/bin/php -v
PHP 5.3.14 (cli) (built: Aug 30 2012 01:52:21)

root@www:/tmp# /usr/php/5.3/bin/php /tmp/iconv_strlen.php 
PHP Notice:  iconv_strlen(): Unknown error (22) in /tmp/iconv_strlen.php on line 
5
PHP Stack trace:
PHP   1. {main}() /tmp/iconv_strlen.php:0
PHP   2. iconv_strlen() /tmp/iconv_strlen.php:5

Notice: iconv_strlen(): Unknown error (22) in /tmp/iconv_strlen.php on line 5

Call Stack:
    0.0002     315392   1. {main}() /tmp/iconv_strlen.php:0
    0.0002     315568   2. iconv_strlen() /tmp/iconv_strlen.php:5


And also on PHP 5.5.3:

root@www:/tmp# /opt/php5/bin/php -v
PHP 5.5.3 (cli) (built: Aug 25 2013 19:41:00) 

root@www:/tmp# /opt/php5/bin/php /tmp/iconv_strlen.php 
PHP Notice:  iconv_strlen(): Unknown error (22) in /tmp/iconv_strlen.php on line 
5

Notice: iconv_strlen(): Unknown error (22) in /tmp/iconv_strlen.php on line 5
 [2013-08-26 09:23 UTC] skrueger at europe dot com
Ah this is so stupid, I was missing the pkg://solaris/system/library/iconv/unicode-core package...

To check if you're missing it too (only works on Solaris 11.1):

$ iconv -l
Failed to open the directory /usr/lib/iconv/geniconvtbl/binarytables/.

When you get that, you need to install the unicode-core pkg and everything (including php's iconv_strlen) will be fine after that.
 [2013-09-08 09:08 UTC] michel02 at hotmail dot com
-Status: No Feedback +Status: Closed
 [2013-09-08 09:08 UTC] michel02 at hotmail dot com
Damn you seem to be correct! Did not spot that untill now.. resolved!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 19 10:01:28 2020 UTC