php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #55147 PHP FPM Usage
Submitted: 2011-07-06 10:15 UTC Modified: 2013-12-29 11:43 UTC
Votes:6
Avg. Score:4.3 ± 0.9
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:4 (80.0%)
From: tapaccos at hotmail dot com Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: 5.3.6 OS: windows 7
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-07-06 10:15 UTC] tapaccos at hotmail dot com
Description:
------------
Documentation on the net states that PHP-FPM does not work on windows when it was a separate entity
However with the inclusion of PHP-FPM in the PHP core it is not clear whether or not this is now possible and how. (Ideally without the need for Cygwin)
In particular would be interested on running PHP with FPM enabled  in conjuction with nginx

Thanks in advance 
Alex

Expected result:
----------------
Documentation stating on how to get PHP to work in FPM to work in windows
Ideally this would be some setting in php.ini to enable.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-13 12:40 UTC] tapaccos at hotmail dot com
Guys its been a week and not even an acknowledgement?
 [2011-07-13 12:43 UTC] philip@php.net
The honest truth? Few people here worry about Windows.
 [2011-07-13 12:46 UTC] tapaccos at hotmail dot com
Thanks Philips for the honest assesment.
We don't all have the luxury to be linux experts!
I mean we must get some credit for using open source software like WAMP on windows :D

Do you know any organisation or site that might otherwise help?
Thanks
Alex
 [2012-02-13 23:29 UTC] brent dot newland at gmail dot com
I would also like to know. I want to set up nginx with PHP-FPM on Windows, but I 
don't want to invest the time in creating the proper build environment and trying 
to compile it myself if it doesn't work (I seem to have problems when setting up 
build environments finding all the dependencies).
 [2012-06-21 08:39 UTC] dave at yougeezer dot co dot uk
I'm in the same boat.  I normally run PHP using mod_fcgid but have had problems on 
Windows with running multiple versions of PHP and timeout issues where it's trying 
to talk to the wrong versions for some requests.  PHP FPM and mod_proxy_fcgi would 
seem to be the way to go and although I have it up and running, I can't seem to 
get the path right ("No Input file specified") and can't figure out where it 
expects to find the FPM conf file.  Even if it was just the basics it'd be great, 
that conf file location would definitely help.
 [2013-12-29 11:43 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2013-12-29 11:43 UTC] krakjoe@php.net
The authors of fpm never intended it to run on windows, or never with any real conviction anyway. It is simply impractical to try and port the code to the windows platform, firstly because that's a substantial task that would surely destabilize fpm, and secondly because windows doesn't do well with hundreds of processes and that's what FPM is intended to do.

Going to mark as "won't fix", only because there's no "we would be bat shit crazy to try and fix this".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 03:01:32 2024 UTC