php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #55111 Make fails with --enable-sockets
Submitted: 2011-07-02 03:15 UTC Modified: 2011-07-11 18:09 UTC
Votes:5
Avg. Score:4.2 ± 1.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: manuel at bouza dot ch Assigned: cataphract
Status: Closed Package: Compile Failure
PHP Version: 5.4SVN-2011-07-02 (SVN) OS: Mac OSX 10.6.7
Private report: No CVE-ID:
 [2011-07-02 03:15 UTC] manuel at bouza dot ch
Description:
------------
PHP Version: 5.4.0alpha2-dev

Make fails with --enable-sockets configuration option. Without --enable-sockets, 
make & make install is successful.

Test script:
---------------
I used the following configuration options:

sudo ./configure \
--prefix=/opt/local/php-5.4-dev \
--with-config-file-path=/opt/local/php-5.4-dev/etc \
--with-fpm-user=_www \
--with-fpm-group=_www \
--enable-fpm \
--with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-pdo-pgsql=/opt/local/lib/postgresql90/bin \
--enable-sockets

Expected result:
----------------
PHP should compile successfully with --enable-sockets.
Socket function should be available in PHP after successful compilation.

Actual result:
--------------
Confuguration runs ok, but make stops with the following error:


/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c: In function 
‘zif_socket_connect’:
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:1556: warning: 
cast from pointer to integer of different size
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c: In function 
‘zif_socket_set_option’:
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2206: error: 
‘MCAST_BLOCK_SOURCE’ undeclared (first use in this function)
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2206: error: 
(Each undeclared identifier is reported only once
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2206: error: 
for each function it appears in.)
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2207: error: 
‘MCAST_UNBLOCK_SOURCE’ undeclared (first use in this function)
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2208: error: 
‘MCAST_JOIN_SOURCE_GROUP’ undeclared (first use in this function)
/Users/mbouza/Downloads/php5.4-201107012030/ext/sockets/sockets.c:2209: error: 
‘MCAST_LEAVE_SOURCE_GROUP’ undeclared (first use in this function)
make: *** [ext/sockets/sockets.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-07-02 06:12 UTC] cataphract@php.net
-Assigned To: +Assigned To: cataphract
 [2011-07-02 06:12 UTC] cataphract@php.net
I thought this has been fixed (though I couldn't confirm myself because I don't have Mac OSX). Assigning to me.
 [2011-07-02 08:03 UTC] cataphract@php.net
Automatic comment from SVN on behalf of cataphract
Revision: http://svn.php.net/viewvc/?view=revision&revision=312810
Log: - Fixed bug #55111 (sockets extension fails to compile on Mac OSX).
 [2011-07-02 08:04 UTC] cataphract@php.net
-Status: Assigned +Status: Feedback
 [2011-07-02 08:04 UTC] cataphract@php.net
Committed fix to SVN. Could you try to compile now?
 [2011-07-02 12:45 UTC] manuel at bouza dot ch
Thank you for looking into this. Just tries with svn branches/PHP_5_4, rev 
312814 and make now stops with the following error:


/bin/sh /Users/mbouza/tmp/php-5.4-sock/libtool --silent --preserve-dup-deps --
mode=compile cc  -Iext/sockets/ -I/Users/mbouza/tmp/php-5.4-sock/ext/sockets/ -
DPHP_ATOM_INC -I/Users/mbouza/tmp/php-5.4-sock/include -I/Users/mbouza/tmp/php-
5.4-sock/main -I/Users/mbouza/tmp/php-5.4-sock -I/Users/mbouza/tmp/php-5.4-
sock/ext/date/lib -I/Users/mbouza/tmp/php-5.4-sock/ext/ereg/regex -
I/usr/include/libxml2 -I/usr/local/include -I/opt/local/include/postgresql90 -
I/Users/mbouza/tmp/php-5.4-sock/ext/sqlite3/libsqlite -I/Users/mbouza/tmp/php-
5.4-sock/TSRM -I/Users/mbouza/tmp/php-5.4-sock/Zend  -no-cpp-precomp  -
I/usr/local/include -g -O2 -fvisibility=hidden -DZEND_SIGNALS  -c 
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/sockets.c -o ext/sockets/sockets.lo 
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/sockets.c: In function 
‘zif_socket_connect’:
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/sockets.c:1556: warning: cast from 
pointer to integer of different size
/bin/sh /Users/mbouza/tmp/php-5.4-sock/libtool --silent --preserve-dup-deps --
mode=compile cc  -Iext/sockets/ -I/Users/mbouza/tmp/php-5.4-sock/ext/sockets/ -
DPHP_ATOM_INC -I/Users/mbouza/tmp/php-5.4-sock/include -I/Users/mbouza/tmp/php-
5.4-sock/main -I/Users/mbouza/tmp/php-5.4-sock -I/Users/mbouza/tmp/php-5.4-
sock/ext/date/lib -I/Users/mbouza/tmp/php-5.4-sock/ext/ereg/regex -
I/usr/include/libxml2 -I/usr/local/include -I/opt/local/include/postgresql90 -
I/Users/mbouza/tmp/php-5.4-sock/ext/sqlite3/libsqlite -I/Users/mbouza/tmp/php-
5.4-sock/TSRM -I/Users/mbouza/tmp/php-5.4-sock/Zend  -no-cpp-precomp  -
I/usr/local/include -g -O2 -fvisibility=hidden -DZEND_SIGNALS  -c 
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c -o 
ext/sockets/multicast.lo 
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c: In function 
‘php_if_index_to_addr4’:
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c:426: error: ‘struct 
ifreq’ has no member named ‘ifr_ifindex’
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c: In function 
‘php_add4_to_if_index’:
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c:506: error: 
‘SIOCGIFINDEX’ undeclared (first use in this function)
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c:506: error: (Each 
undeclared identifier is reported only once
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c:506: error: for each 
function it appears in.)
/Users/mbouza/tmp/php-5.4-sock/ext/sockets/multicast.c:513: error: ‘struct 
ifreq’ has no member named ‘ifr_ifindex’
make: *** [ext/sockets/multicast.lo] Error 1
 [2011-07-04 04:30 UTC] cataphract@php.net
-Status: Feedback +Status: Assigned
 [2011-07-08 16:00 UTC] me at sumardi dot net
I have the same issue on Mac OS X.

SVN rev. 313075
 [2011-07-10 16:41 UTC] carlos dot lazcano at cursor dot cl
I get the same error with version php5.4-201107101830

/bin/sh /Users/clazcano/Compilados/php5.4-201107101830/libtool --silent --
preserve-dup-deps --mode=compile cc  -Iext/sockets/ -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/ -DPHP_ATOM_INC -
I/Users/clazcano/Compilados/php5.4-201107101830/include -
I/Users/clazcano/Compilados/php5.4-201107101830/main -
I/Users/clazcano/Compilados/php5.4-201107101830 -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/date/lib -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/ereg/regex -
I/usr/include/libxml2 -I/usr/local/include -I/usr/local/include/freetype2 -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/mbstring/oniguruma -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/mbstring/libmbfl -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/mbstring/libmbfl/mbfl -
I/Users/clazcano/Compilados/php5.4-201107101830/ext/sqlite3/libsqlite -
I/opt/local/include/libxml2 -I/Users/clazcano/Compilados/php5.4-
201107101830/TSRM -I/Users/clazcano/Compilados/php5.4-201107101830/Zend  -no-
cpp-precomp  -I/usr/local/include -I/usr/local/include -L/usr/local/lib -
fvisibility=hidden -DZTS -DZEND_SIGNALS  -c /Users/clazcano/Compilados/php5.4-
201107101830/ext/sockets/multicast.c -o ext/sockets/multicast.lo 
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c: In 
function ‘php_if_index_to_addr4’:
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c:426: 
error: ‘struct ifreq’ has no member named ‘ifr_ifindex’
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c: In 
function ‘php_add4_to_if_index’:
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c:506: 
error: ‘SIOCGIFINDEX’ undeclared (first use in this function)
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c:506: 
error: (Each undeclared identifier is reported only once
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c:506: 
error: for each function it appears in.)
/Users/clazcano/Compilados/php5.4-201107101830/ext/sockets/multicast.c:513: 
error: ‘struct ifreq’ has no member named ‘ifr_ifindex’
 [2011-07-10 17:07 UTC] carlos dot lazcano at cursor dot cl
I have the same issue on Mac OS X snow 10.6.6.

SVN rev. 313120


./configure \
--prefix=/usr/local/php5 \
--with-apxs2=/usr/local/apache2/bin/apxs \
--with-bz2=/usr  \
--with-config-file-scan-dir=/usr/local/php5/php.d \
--with-curl \
--with-freetype-dir=/usr/local/php5 \
--with-gd \
--with-gettext \
--with-iconv-dir=/usr \
--with-imap-ssl=/usr/local \
--with-imap=/usr/local \
--with-jpeg-dir=/usr/local/php5 \
--with-kerberos=/usr \
--with-ldap \
--with-libxml-dir=shared,/usr/local/php5 \
--with-mcrypt \
--with-mhash \
--with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-openssl=/usr \
--with-png-dir=/usr/local/php5 \
--with-snmp=/usr \
--with-t1lib=/usr/local/php5 \
--with-xmlrpc \
--with-xsl \
--with-zlib-dir=/usr \
--with-zlib=/usr \
--enable-bcmath \
--enable-calendar \
--enable-cgi \
--enable-exif \
--enable-ftp \
--enable-gd-native-ttf \
--enable-mbstring \
--enable-pcntl \
--enable-shmop  \
--enable-soap \
--enable-sockets \
--enable-sysvmsg \
--enable-sysvsem \
--enable-sysvshm \
--enable-wddx \
--enable-zip
 [2011-07-10 20:39 UTC] cataphract@php.net
-Status: Assigned +Status: Feedback
 [2011-07-10 20:39 UTC] cataphract@php.net
Please test this patch: http://nebm.ist.utl.pt/~glopes/misc/bug55111.diff
 [2011-07-11 04:29 UTC] cataphract@php.net
Automatic comment from SVN on behalf of cataphract
Revision: http://svn.php.net/viewvc/?view=revision&revision=313126
Log: - Further fix for bug #55111 (compilation failure of ext/sockets in Mac OS X).
 [2011-07-11 16:37 UTC] manuel at bouza dot ch
-Status: Feedback +Status: Assigned
 [2011-07-11 16:37 UTC] manuel at bouza dot ch
I tried to compile from revision 313151 and it was successful. Calling 
socket_create successfully created a socket ressource in PHP.

Seems you patch was already applied in this revision, because I got the 
following message trying to patch the file:

> sudo patch -b -i ./bug55111.diff /tmp/php-5.4-dev-
patched/ext/sockets/multicast.c
patching file /tmp/php-5.4-dev-patched/ext/sockets/multicast.c
Reversed (or previously applied) patch detected!  Assume -R? [n]

Thanks for your help!
 [2011-07-11 18:09 UTC] cataphract@php.net
-Status: Assigned +Status: Closed
 [2012-04-18 09:50 UTC] laruence@php.net
Automatic comment on behalf of cataphract
Revision: http://git.php.net/?p=php-src.git;a=commit;h=be0e5d7f957f881abc3c91c1c72590c852f77aef
Log: - Fixed bug #55111 (sockets extension fails to compile on Mac OSX).
 [2012-07-24 23:41 UTC] rasmus@php.net
Automatic comment on behalf of cataphract
Revision: http://git.php.net/?p=php-src.git;a=commit;h=be0e5d7f957f881abc3c91c1c72590c852f77aef
Log: - Fixed bug #55111 (sockets extension fails to compile on Mac OSX).
 [2013-11-17 09:37 UTC] laruence@php.net
Automatic comment on behalf of cataphract
Revision: http://git.php.net/?p=php-src.git;a=commit;h=be0e5d7f957f881abc3c91c1c72590c852f77aef
Log: - Fixed bug #55111 (sockets extension fails to compile on Mac OSX).
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 16:02:23 2014 UTC