php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54913 Missing 3 functions from documentation
Submitted: 2011-05-24 06:00 UTC Modified: 2013-05-18 00:22 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (33.3%)
From: oakwhiz at yahoo dot ca Assigned:
Status: Not a bug Package: *Encryption and hash functions
PHP Version: 5.3SVN-2011-05-24 (SVN) OS: Ubuntu 10.10
Private report: No CVE-ID: None
 [2011-05-24 06:00 UTC] oakwhiz at yahoo dot ca
Description:
------------
---
From manual page: http://www.php.net/ref.gnupg
---

The following functions in the gnupg extension exist but no documentation is provided for them:

gnupg_deletekey
gnupg_gettrustlist
gnupg_listsignatures

Test script:
---------------
<?php

if (!extension_loaded('gnupg')) {
	if (!dl('gnupg.so')) {
		echo "GPG extension not loaded";
	}
}

print_r(get_extension_funcs("gnupg"));

?>

Actual result:
--------------
Array
(
    [0] => gnupg_init
    [1] => gnupg_keyinfo
    [2] => gnupg_sign
    [3] => gnupg_verify
    [4] => gnupg_clearsignkeys
    [5] => gnupg_clearencryptkeys
    [6] => gnupg_cleardecryptkeys
    [7] => gnupg_setarmor
    [8] => gnupg_encrypt
    [9] => gnupg_decrypt
    [10] => gnupg_export
    [11] => gnupg_import
    [12] => gnupg_getprotocol
    [13] => gnupg_setsignmode
    [14] => gnupg_encryptsign
    [15] => gnupg_decryptverify
    [16] => gnupg_geterror
    [17] => gnupg_addsignkey
    [18] => gnupg_addencryptkey
    [19] => gnupg_adddecryptkey
    [20] => gnupg_deletekey
    [21] => gnupg_gettrustlist
    [22] => gnupg_listsignatures
    [23] => gnupg_seterrormode
)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-05-18 00:22 UTC] vrana@php.net
We have other tools to track missing functions.
 [2013-05-18 00:22 UTC] vrana@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Jun 22 17:01:44 2018 UTC