php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54666 equal Query string in example
Submitted: 2011-05-05 12:51 UTC Modified: 2011-05-05 23:52 UTC
From: schudax at gmx dot de Assigned: wiesemann (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 5.2.17 OS: Windows XP
Private report: No CVE-ID: None
 [2011-05-05 12:51 UTC] schudax at gmx dot de
Description:
------------
---
From manual page: http://www.php.net/mysqli.real-escape-string#Beispiele
---
Hello,
i think, in the example which should show the use of the function real_escape_string will be no difference when executing the code because the use of real_escape_string function is missing. Both query-strings are the same.

Greeeeetz,
Schudax

Expected result:
----------------
Correction of the example


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-05 23:52 UTC] wiesemann@php.net
-Status: Open +Status: Bogus -Assigned To: +Assigned To: wiesemann
 [2011-05-05 23:52 UTC] wiesemann@php.net
Both examples (OO and procedural) are showing the usage of this function:
$city = $mysqli->real_escape_string($city);
$city = mysqli_real_escape_string($link, $city);

I guess that you've overlooked these calls directly before the second query() calls.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 30 03:01:26 2020 UTC