php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5465 Save handler "mm" -> segv
Submitted: 2000-07-08 17:45 UTC Modified: 2000-07-11 05:20 UTC
From: karajannis at gmd dot de Assigned:
Status: Closed Package: Session related
PHP Version: 4.0 Latest CVS (08/07/2000) OS: Linux, Solaris 7
Private report: No CVE-ID: None
 [2000-07-08 17:45 UTC] karajannis at gmd dot de
The problem seems to be that the mm handler doesn't get installed correctly, since on request shutdown, the error log reports:

mod_files.c(217) : Block 0x422ED010 status:
Beginning:      Overrun (magic=0x001D1860, expected=0x7312F8DC)
      End:      Unknown
which seems to indicate that the wrong save handler (files) is called.
Files work ok.

Backtrace:
#0  _efree (ptr=0x0, __zend_filename=0x81d9c10 "mod_files.c", __zend_lineno=218, __zend_orig_filename=0x0, __zend_orig_lineno=0) at zend_alloc.c:189
#1  0x80c3e8f in _ps_close_files (mod_data=0x8242d0c) at mod_files.c:218
#2  0x80c2ec1 in php_rshutdown_session_globals () at session.c:1303
#3  0x80c3683 in php_rshutdown_session (type=1, module_number=12) at session.c:1345
#4  0x8111925 in module_registry_cleanup (module=0x828e4f8) at zend_API.c:858
#5  0x8114ed5 in zend_hash_apply (ht=0x8249b20, apply_func=0x81118f4 <module_registry_cleanup>) at zend_hash.c:672
#6  0x81111ee in zend_deactivate_modules () at zend.c:503
#7  0x80a4c2e in php_request_shutdown (dummy=0x0) at main.c:670
#8  0x80a2d80 in php_apache_request_shutdown (dummy=0x0) at mod_php4.c:301
#9  0x814200b in run_cleanups (c=0x829baf0) at alloc.c:1940
#10 0x8140d88 in ap_clear_pool (a=0x8251c18) at alloc.c:683
#11 0x8140dec in ap_destroy_pool (a=0x8251c18) at alloc.c:713
#12 0x8140d5c in ap_clear_pool (a=0x8270a18) at alloc.c:676
#13 0x814cd4e in child_main (child_num_arg=0) at http_main.c:3990
#14 0x814d27c in make_child (s=0x824dc10, slot=0, now=962984448) at http_main.c:4380
#15 0x814d3a3 in startup_children (number_to_start=5) at http_main.c:4462
#16 0x814d85c in standalone_main (argc=2, argv=0xbffffad4) at http_main.c:4750
#17 0x814df1f in main (argc=2, argv=0xbffffad4) at http_main.c:5092

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-11 05:20 UTC] sas at cvs dot php dot net
This was caused by an inproper order of restoring INI entries. Fixed in CVS. Thanks for your report.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 17:05:44 2022 UTC