php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54472 $http_response_header values limited to 1023 characters
Submitted: 2011-04-05 19:45 UTC Modified: 2012-11-14 18:10 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: laurent dot piroelle at brainsonic dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 5.2.17 OS: Windows XP
Private report: No CVE-ID: None
 [2011-04-05 19:45 UTC] laurent dot piroelle at brainsonic dot com
Description:
------------
The documentation should mention that the values in the variable $http_response_header are limited to 1023 characters. A value longer than 1023 characters will be split into multiple keys/values into the array.

---
From manual page: http://www.php.net/reserved.variables.httpresponseheader
---


Expected result:
----------------
An updated documentation page http://www.php.net/reserved.variables.httpresponseheader


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-06 22:45 UTC] yannick@php.net
-Package: Translation problem +Package: Documentation problem
 [2012-11-14 18:10 UTC] googleguy@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

I can not reproduce this behavior using the latest PHP release branches 5.3.18 
and 5.4.8. I also can't find any relevant code that would indicate what you're 
saying is expected behavior. I have no problem getting headers that are longer 
than 1023 bytes in length from the $http_response_header magic variable or the 
get_headers() function.

If you have any code to reproduce this behavior please reopen the bug report 
with a reproducible example and include the PHP version you used.

Thanks.
 [2012-11-14 18:10 UTC] googleguy@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 18:01:26 2020 UTC