php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54467 microseconds is always 000000
Submitted: 2011-04-04 23:41 UTC Modified: 2011-04-06 09:21 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mark dot gustafson at hotmail dot com Assigned:
Status: Duplicate Package: Date/time related
PHP Version: 5.3.6 OS: Win2003K
Private report: No CVE-ID: None
 [2011-04-04 23:41 UTC] mark dot gustafson at hotmail dot com
Description:
------------
I'm using Win2003K (fully patched), Apache 2.2.17 (Win32) and PHP 5.3.6.

Please run the following two lines in a PHP file:

$sTimeStamp = date("Y_m_d_H_i_s_u_");
print($sTimeStamp);

It will display as so:
2011_04_04_14_20_55_000000_

Every time I run the file, the microseconds is always 000000.

I hope this really is a bug and that you enjoy fixing it.
Thank You (!!!) and Best Regards.


Test script:
---------------
see above

Expected result:
----------------
see above


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-04 23:44 UTC] mark dot gustafson at hotmail dot com
-: nmsalinas@yahoo.com +: mark dot gustafson at hotmail dot com
 [2011-04-04 23:44 UTC] mark dot gustafson at hotmail dot com
small edit.
 [2011-04-06 09:21 UTC] aharvey@php.net
-Status: Open +Status: Duplicate -Package: *General Issues +Package: Date/time related
 [2011-04-06 09:21 UTC] aharvey@php.net
Duplicate of bug #41806.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC