php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5436 mail() function just hung for ever (both for ISAPI and CGI module)
Submitted: 2000-07-07 16:12 UTC Modified: 2000-08-20 02:53 UTC
From: papagel at ceid dot upatras dot gr Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: Windows 2000
Private report: No CVE-ID: None

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-27 21:12 UTC] zak@php.net
Please provide more information - what is your SMTP setting in your php.ini file.

Also, please read http://bugs.php.net/bugs-dos-and-donts.php
 [2000-08-20 02:53 UTC] sniper@php.net
No feedback, not enough info, should be fixed in CVS.

--Jani
 [2002-04-21 15:23 UTC] ducvan at emayco dot com
Hi;

I have a similar problem. PHP mail() seem no to work. I am using php-4.1.2, apache_1.3.24-win32-x86-no_src, mysql-3.23.49. I am using MS-Exchange server as my mail server.  All run on Window 2000 on the same box.

Here the problem. Every I try to send a mail using php mail() function to the internet e.g. ( who@yahho.com ), it will NOT work. 

It work only within my network. I can send mail to my exchange locally e.g. ( who@emayco.com ). It's WORK!

I have try the following setting the SMTP to:
SMTP =pc.com
SMTP =localhost
SMTP =127.0.0.1
SMTP =192.168.1.200
SMTP =www.pc.com

I have copy php.ini file to winnt, winnt/system, winnt/system32. 
I have try modified mail and sendmail from "\n" to "\r\n".

Please help me.......

Can some one help me? Here is my setting in php.ini and it only work locally.

[mail function]
; For Win32 only.
SMTP =mserver.pc.com

; For Win32 only.
sendmail_from =who@pc.com

; For Unix only.  You may supply arguments as well (default: 'sendmail -t -i').
;sendmail_path =/

PHP user
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Nov 30 04:05:54 2022 UTC