php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #54355 Test for de_DE doesn't use UTF-8 locales
Submitted: 2011-03-23 09:27 UTC Modified: 2011-03-23 09:59 UTC
From: ondrej at sury dot org Assigned: aharvey (profile)
Status: Closed Package: *Languages/Translation
PHP Version: 5.3.6 OS: Any
Private report: No CVE-ID: None
 [2011-03-23 09:27 UTC] ondrej at sury dot org
Description:
------------
The tests in tests/lang/bug30638.phpt and tests/lang/034.phpt use only ISO-8859-1 which is rarely supported on current distributions.

I have also normalized both tests to use same set of locale names.

Test script:
---------------
<?php

if (setlocale(LC_NUMERIC, "de_DE", "de", "german", "ge", "de_DE.ISO8859-1") === FALSE) {
  print "skip";
}

?>


Expected result:
----------------
// no output

Actual result:
--------------
skip

Patches

tests-lang-use-utf8.patch (last revision 2011-03-23 08:29 UTC by ondrej at sury dot org)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-23 09:54 UTC] aharvey@php.net
-Status: Open +Status: Assigned -Package: Gettext related +Package: *Languages/Translation -Assigned To: +Assigned To: aharvey
 [2011-03-23 09:59 UTC] aharvey@php.net
Automatic comment from SVN on behalf of aharvey
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=309586
Log: Implement request #54355 (Test for de_DE doesn't use UTF-8 locales). Patch by
Ondřej Surý.
 [2011-03-23 09:59 UTC] aharvey@php.net
-Status: Assigned +Status: Closed
 [2011-03-23 09:59 UTC] aharvey@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Thanks Ondřej!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 11:01:24 2020 UTC