php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54204 Can't set a value with a PATH section in php.ini
Submitted: 2011-03-09 16:22 UTC Modified: 2011-07-23 06:21 UTC
Votes:24
Avg. Score:4.0 ± 0.3
Reproduced:24 of 24 (100.0%)
Same Version:10 (41.7%)
Same OS:24 (100.0%)
From: carsten_sttgt at gmx dot de Assigned: pajoye
Status: Closed Package: *General Issues
PHP Version: 5.3.6RC3 OS: Windows
Private report: No CVE-ID:
 [2011-03-09 16:22 UTC] carsten_sttgt at gmx dot de
Description:
------------
I can't set a value inside a PATH section. The PATH section is for the current script.

This only happens with Windows. With *nix it's working as expected.

Additionally this only happens with PHP5.3.6RC2, but not with 5.3.5.
 


Test script:
---------------
adding this to "php.ini":
[PATH=C:/Users/Public/Documents/htdocs/]
upload_max_filesize = 5M

And then accessing a phpinfo.php through CGI.
<?php
phpinfo();
?>


Expected result:
----------------
upload_max_filesize	5M		2M


Actual result:
--------------
upload_max_filesize	2M		2M


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-11 09:26 UTC] carsten_sttgt at gmx dot de
-PHP Version: 5.3.6RC2 +PHP Version: 5.3.6RC3
 [2011-03-11 09:26 UTC] carsten_sttgt at gmx dot de
Still exists in 5.3.6RC3
 [2011-03-19 00:16 UTC] whistl0r+php at googlemail dot com
I can confirm this bug in the final 5.3.6 release.
 [2011-07-13 12:16 UTC] pajoye@php.net
-Status: Open +Status: Assigned -Package: CGI related +Package: *General Issues -Assigned To: +Assigned To: pajoye
 [2011-07-18 06:25 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=313371
Log: - fix bug #54204, Can't set a value with a PATH section in php.ini
 [2011-07-18 06:26 UTC] pajoye@php.net
-Status: Assigned +Status: Feedback
 [2011-07-18 06:26 UTC] pajoye@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz

For Windows:

  http://windows.php.net/snapshots/

If it works I will backport the fix to 5.3 as well.
 [2011-07-18 09:39 UTC] whistl0r+php at googlemail dot com
Hi,

I can confirm, that this bug is solved in the latest 5.4 snapshot (I tested php-5.4-nts-windows-vc9-x86-r313371). Thank you!

Will we see the backport in 5.3.7 or is it too late?
 [2011-07-18 11:13 UTC] pajoye@php.net
Yes, it will be in 5.3.7. I will commit the fix to 5.3 later today/tomorrow.
 [2011-07-18 11:13 UTC] pajoye@php.net
-Status: Feedback +Status: Assigned
 [2011-07-18 17:00 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=313404
Log: - MFH: Fixed bug #54204 (Can't set a value with a PATH section in php.ini).
 [2011-07-23 06:21 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 [2011-07-23 06:21 UTC] pajoye@php.net
fixed in all branches
 [2012-04-18 09:49 UTC] laruence@php.net
Automatic comment on behalf of pajoye
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ba22d8a37b0a0cd4e5f5fd537c58d72d8212298c
Log: - fix bug #54204, Can't set a value with a PATH section in php.ini
 [2012-07-24 23:40 UTC] rasmus@php.net
Automatic comment on behalf of pajoye
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ba22d8a37b0a0cd4e5f5fd537c58d72d8212298c
Log: - fix bug #54204, Can't set a value with a PATH section in php.ini
 [2013-11-17 09:37 UTC] laruence@php.net
Automatic comment on behalf of pajoye
Revision: http://git.php.net/?p=php-src.git;a=commit;h=ba22d8a37b0a0cd4e5f5fd537c58d72d8212298c
Log: - fix bug #54204, Can't set a value with a PATH section in php.ini
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 03:02:48 2014 UTC