php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54160 [FR] French translation mistake in str_replace function
Submitted: 2011-03-04 11:47 UTC Modified: 2011-03-11 09:39 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: glb_fr at hotmail dot com Assigned: yannick (profile)
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2011-03-04 11:47 UTC] glb_fr at hotmail dot com
Description:
------------
---
From manual page: http://www.php.net/function.str-replace#Liste de paramètres
---
The description of the count parameter (in the french documentation page) could 
lead to an understanding mistake.
The French documentation is:
'Si fourni, définira le nombre de remplacements à effectuer.'
It means:
'If passed, this will set the number of replacements to perform.'

To be conform to the English documentation, it should be written:
'Si fournie, cette variable contiendra le nombre de remplacements effectués.' 

You can check the French documentation of the preg_replace function to validate 
this translation


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-11 09:37 UTC] yannick@php.net
-Summary: French translation mistake in str_replace function +Summary: [FR] French translation mistake in str_replace function
 [2011-03-11 09:39 UTC] yannick@php.net
Automatic comment from SVN on behalf of yannick
Revision: http://svn.php.net/viewvc/?view=revision&revision=309113
Log: Fix bug #54160
 [2011-03-11 09:39 UTC] yannick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: yannick
 [2011-03-11 09:40 UTC] yannick@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2020-12-30 12:49 UTC] nikic@php.net
Automatic comment on behalf of yannick
Revision: http://git.php.net/?p=doc/fr.git;a=commit;h=7f53eed4b7ab6521494ae3592a919086aa2e81e3
Log: Fix bug #54160
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 19 20:03:14 2022 UTC