php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54138 DOMNode::getLineNo() doesn't return line number higher than 65535
Submitted: 2011-03-02 15:23 UTC Modified: 2015-06-08 11:07 UTC
From: dmitrij at stepanov dot lv Assigned: cmb (profile)
Status: Closed Package: XML Reader
PHP Version: 5.6.9 OS: *
Private report: No CVE-ID: None
 [2011-03-02 15:23 UTC] dmitrij at stepanov dot lv
Description:
------------
DOMNode::getLineNo() doesn't return line number higher than 65535.

I assume that unsigned short is used for file line enumeration either in XMLReader 
or DOMNode internals.

Test script:
---------------
Try reading with XMLReader an XML file that has more than 65535 lines.

Then, when line nr. > 65535 is reached, call XMLReader::expand()->getLineNo().

Expected result:
----------------
Correct line number.

Actual result:
--------------
65535 for lines, higher than 65525.

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-02 16:17 UTC] rrichards@php.net
-Status: Open +Status: Bogus
 [2011-03-02 16:17 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Known limitation of libxml2
 [2012-06-19 12:42 UTC] hanskrentel at yahoo dot de
The function DOMNode::getLineNo() is not able to return a line number higher 
than 65535.

Test Script:

<?php
$xml = "<?xml version=\"1.0\"?><root>".str_repeat("\n", 65537)
       ."<mix>end</mix>\n<mix>end</mix></root>"
       ;
echo dom_import_simplexml(
         end(simplexml_load_string($xml)->xpath('//text()'))
     )->getLineNo()
     ;
?>

Expected result: 65537

Actual result: 65535

Summary: Reported back in 2007, upstream does not know how to fix this w/o 
breaking stuff (binary compatibility). 
It's also worth to mention that normally files with more than 65k lines aren't 
written by hand so don't require that 
type of functionality. Naturally this is subjective.

To fix this this requires a different upstream/patch of one of the underlying 
libraries, e.g. libxml2. The debian 
ticket has a patch.

https://mail.gnome.org/archives/xml/2007-October/msg00002.html

http://lxr.php.net/xref/PHP_5_3/ext/dom/node.c#1955

http://lxr.php.net/xref/PHP_5_3/ext/libxml/php_libxml2.def#419

http://xmlsoft.org/html/libxml-tree.html#xmlGetLineNo

https://bugzilla.gnome.org/show_bug.cgi?id=676026

http://stackoverflow.com/a/11099693/367456

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=445961
 [2013-10-25 21:09 UTC] ruud at vanmelick dot com
This is solved in libxml2 version 2.9+.
However, you have to explicitly tell libxml to support it, which you can do in PHP by using using the options parameter in functions like DOMDocument::load (option 2^22 = 4194304 = XML_PARSE_BIG_LINES). Currently there's no PHP libxml constant for that purpose.
 [2015-06-03 12:56 UTC] cmb@php.net
-Status: Not a bug +Status: Re-Opened -Assigned To: +Assigned To: cmb
 [2015-06-03 12:56 UTC] cmb@php.net
Re-opened according to Ruud's comment. Not sure, whether that should be categorized as feature request, though.
 [2015-06-03 23:15 UTC] cmb@php.net
-Operating System: Windows 7 +Operating System: * -PHP Version: 5.3.5 +PHP Version: 5.6.9
 [2015-06-03 23:15 UTC] cmb@php.net
Thanks for the hint, Ruud. Indeed, as of libxml2 2.9.0 there is
the constant XML_PARSE_BIG_LINES available:
<https://git.gnome.org/browse/libxml2/commit/include/libxml/parser.h?id=968a03a2e54f5bcf53089f5e3c8f790dbe0bf824>.

I'll make a PR to add a respective constant to PHP, so users don't
have to rely on a hard to remember and potentially changing
numeric value.
 [2015-06-03 23:16 UTC] cmb@php.net
-Assigned To: cmb +Assigned To:
 [2015-06-08 11:07 UTC] cmb@php.net
-Status: Re-Opened +Status: Closed -Assigned To: +Assigned To: cmb
 [2015-06-08 11:07 UTC] cmb@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC