php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #54088 Some unicode chars not being displayed in IE.
Submitted: 2011-02-24 12:50 UTC Modified: 2012-11-12 04:02 UTC
From: rquadling@php.net Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-02-24 12:50 UTC] rquadling@php.net
Description:
------------
On http://docs.php.net/manual/en/language.types.integer.php, the first line 
reads ...

"An integer is a number of the set ℤ = {..., -2, -1, 0, 1, 2, ...}."

In Google Chrome V11.0.672.2 dev and in Firefox V3.6.13, the ℤ (a Double-Struck 
Capital Z :: ࡌ) is displayed correctly.

In IE8.0.6001.18702, the character displayed is the usual box character for an 
unknown glyph. This is also true in the downloaded CHM files (as they use IE to 
render the page) as well as all the compatibility and quirks 
mode (tested within IE8).

It seems that the font being used is Arial. In the Arial font on my machine 
(V3.00 and digitally signed to be an authentic font), this glyph is not present.

Adding "Arial Unicode MS" to the font-family, then this character is displayed 
correctly.

The issue is not an encoding issue. The character is correctly encoded. It is 
just the font being used by IE doesn't have the glyph.

But replacing the entire site's font isn't something I'd like to do just to fix 
what so far is 1 character.

One way would be to change the ℤ to a Z. http://en.wikipedia.org/wiki/Integer 
says this is one way this symbol is shown.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-24 15:18 UTC] carsten_sttgt at gmx dot de
> In IE8.0.6001.18702, the character displayed is the usual box character
> for an unknown glyph. This is also true in the downloaded CHM files
> (as they use IE > to render the page) as well as all the compatibility and
> quirks mode (tested within IE8).

Which OS? On Win7 I can see the "ℤ" in Internet Explorer 8.0.7600.16385. Of course it looks better with "Arial Unicode MS".
I don't know which replacement font IE is using (looks the same like this character in the bug tracker with Firefox.

Regards,
Carsten
 [2011-02-24 17:19 UTC] rquadling@php.net
Using Windows XP SP3 (my local machine) and a Windows Server 2003 R2 Standard Edition (One of my VM-d dev servers - used for php-src) using IE8.0.6001.18702 also.


On Windows Server 2008 Enterprise (another VM-d dev server used IIS7 Development) using IE8.0.6001.19019, the ℤ is shown.

Cutting and pasting from a working IE into MS Word reveals that the font is Cambria Math.

If I do the same exercise with Chrome and Firefox, the same font.

Doing this from my local IE8 (where the incorrect glyph is displayed), the copied data is pasted correctly and shows as Cambria Math.

So it seems to only be IE8.0.6001.18702. I've no idea about older versions.
 [2011-02-24 18:51 UTC] carsten_sttgt at gmx dot de
> So it seems to only be IE8.0.6001.18702. I've no idea about older versions.

Ah, on my XP SP3 box I have the same IE8. There is also no Office (and thus no Arial Unicode MS) on this box. And I can reproduce the issue. IE is not showing the "ℤ" and Firefox is showing it ("Cambria Math" is installed).

Regards,
Carsten
 [2011-12-05 23:26 UTC] frozenfire@php.net
Automatic comment from SVN on behalf of frozenfire
Revision: http://svn.php.net/viewvc/?view=revision&revision=320469
Log: Replaced Zahlen literal with character entity. Fixes bug #54088.
 [2011-12-05 23:26 UTC] frozenfire@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: frozenfire
 [2011-12-05 23:26 UTC] frozenfire@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2011-12-06 14:45 UTC] rquadling@php.net
-Status: Closed +Status: Re-Opened
 [2011-12-06 14:45 UTC] rquadling@php.net
Using ℤ or ℤ is the same thing. Just different encoding. Encoding isn't the 
issue. IE8 (and maybe other versions of IE) doesn't automatically substitute the 
font.

Only real option is to use Z and not ℤ, I think.
 [2011-12-06 22:03 UTC] frozenfire@php.net
-Assigned To: frozenfire +Assigned To:
 [2012-11-12 04:02 UTC] aharvey@php.net
This appears to work fine in IE on Windows 7 and later. I fear that if we change this to Z, we'll just get another bug saying "it's ℤ", so let's just leave it and wait for older versions of IE and Windows to gradually die out.
 [2012-11-12 04:02 UTC] aharvey@php.net
-Status: Re-Opened +Status: Wont fix
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 04:01:31 2024 UTC