php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54068 php installation could not be completed
Submitted: 2011-02-22 09:46 UTC Modified: 2015-06-09 16:02 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:2 of 3 (66.7%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: PSeidel at info-tech dot biz Assigned: cmb (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.3.5 OS: Windows 7 64bit
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-02-22 09:46 UTC] PSeidel at info-tech dot biz
Description:
------------
Hello,

I've got Windows 7 64bit. I installed Apache HTTP Server (httpd) 2.2.17 (it is stated, that it is the best available version) - i tried it with both install packages:

# Win32 Binary without crypto (no mod_ssl) (MSI Installer): httpd-2.2.17-win32-x86-no_ssl.msi [PGP] [MD5] [SHA1]
# Win32 Binary including OpenSSL 0.9.8o (MSI Installer): httpd-2.2.17-win32-x86-openssl-0.9.8o.msi

But I am still not able to install php, using following package:
VC6 x86 Thread Safe (2011-Jan-06 18:56:08)
php-5.3.5-Win32-VC6-x86.msi

(VC6 should be used for Apache Web Server - VC9 only for IIS, right?)
(I did choose the Thread Safe version, because it features the "Apache 2.2.x Module" integration in the install wizzard. - Is this correct? What is the actual differance to Non Thread Safe?)

ERROR:
The error message which I am receiving at the very end of the install process is following:
"There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor."

I did also read following bug requests:
http://bugs.php.net/bug.php?id=43639
http://bugs.php.net/bug.php?id=47134

But the snaps do not include Windows a version and giving full access rights to the Apache Web Server folder did not have any effect. - I am lost! :(
Please help.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-01-27 16:10 UTC] jan at lanteraudio dot nl
Had this problem too, but with php-5.2.17-Win32-VC6-x86.msi and apache 2.0 on Win XP pro sp3.
Initially installed well, but had to reinstall, next the installer came up with the message reported by original poster every time.
Until at last I ran again and forgot to enter the correct path to the apache config file. Now the installer reported that it could not find the config file, but finished the installation none the less (and I still had the orig commands for php5 in the config file, so that solved it for me).
Turns out I edited something in the config the installer does not like: I added a comment line containing the actual path to the php directory, as the initial install had not entered it correctly (may be another bug).
Hope this helps fixing the bug (the installer could eg report having problems with the config file). cheers.
 [2015-06-09 16:02 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2015-06-09 16:02 UTC] cmb@php.net
This ticket is obsolete, because Microsoft installer binaries
(.msi) are not distributed anymore as of PHP 5.4.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 20:01:23 2020 UTC