php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53938 php-fpm overwrites xdebug idekey
Submitted: 2011-02-06 14:51 UTC Modified: 2011-07-02 14:02 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: miha dot vrhovnik at domenca dot si Assigned: fat (profile)
Status: Not a bug Package: FPM related
PHP Version: 5.3.5 OS: Linux
Private report: No CVE-ID: None
 [2011-02-06 14:51 UTC] miha dot vrhovnik at domenca dot si
Description:
------------
xdebug's idekey is somewhat set to the user php-fpm is running under.
i.e. if php-fpm is set to run under user nobody xdebug.idekey becomes nobody, if running under www-data then it becomes www-data.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-06 17:29 UTC] fat@php.net
-Status: Open +Status: Feedback
 [2011-02-06 17:29 UTC] fat@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


I don't understand what's the problem. Can you please describe it with the more 
infos you can ?

Thx
 [2011-02-06 17:29 UTC] fat@php.net
-Assigned To: +Assigned To: fat
 [2011-02-07 08:26 UTC] miha dot vrhovnik at domenca dot si
-Status: Feedback +Status: Assigned
 [2011-02-07 08:26 UTC] miha dot vrhovnik at domenca dot si
The xdebug.idekey is set to default in xdebug.ini
root@mvubdevel:/etc/php5# grep -R idekey *
cli/conf.d/xdebug.ini:xdebug.idekey=default
conf.d/xdebug.ini:xdebug.idekey=default
fpm/conf.d/xdebug.ini:xdebug.idekey=default

Running phpinfo() in browser it outputs that the local setting for xdebug.idekey is www-data, which is the user php-fpm is running under. To confirm that I've set up php-fpm to run under user nobody and local setting for xdebug.idekey became nobody

Trying to provide more info I've found out that running the following results in the same problem.. 
root@mvubdevel:~# php -r 'phpinfo();' | grep idekey
xdebug.idekey => root => default

So it seems that the problem might be in xdebug itself. I'm taking this to xdebug tracker sorry for bothering you.
 [2011-07-02 14:02 UTC] fat@php.net
-Status: Assigned +Status: Bogus
 [2011-07-02 14:02 UTC] fat@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

thx
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC