php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53907 if ('29.10' == '29.1'){echo "yanlış";}
Submitted: 2011-02-02 12:21 UTC Modified: 2011-02-02 16:09 UTC
From: aytunc77 at hotmail dot com Assigned:
Status: Not a bug Package: Systems problem
PHP Version: 5.2.17 OS: Linux Centos
Private report: No CVE-ID: None
 [2011-02-02 12:21 UTC] aytunc77 at hotmail dot com
Description:
------------
if ('29.10' == '29.1'){echo "yanlış";}

burada sonuç doğru döndürüyor halbuki şartın sonucu false olmalı.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-02 16:09 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2011-02-02 16:09 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

That's a string comparison.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 03:01:26 2019 UTC