php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5386 Apache process die when trying to connect to oracle
Submitted: 2000-07-05 18:48 UTC Modified: 2006-07-17 09:05 UTC
From: fjoos at free dot fr Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 4.0.0 OS: RedHat 6.0 or Mandrake 7.0 + Apa
Private report: No CVE-ID: None
 [2000-07-05 18:48 UTC] fjoos at free dot fr
Hi,

I am trying to use oracle 8i (8.1.6) with php4 (static module for apache).

Compilation works fine, oracle is ok, php works fine until I try to connect to oracle with OCILogon: the process die and what I get in apache error log is "child pid a_pid  exit signal Segmentation Fault (11) ".

I have tried Mandrake 7.02 and Red Hat Linux 6.0, php4b3, php4.0 and php4.0.1pl2. Some other bug reports (#4601) indicated to add -lpthread for apache linking but it doesn't work for me...(I have added it in Makefile files and did make but it doesn't work...)

With older version of oracle (8.0.5) and linux (Red Hat 5.2) everything work fine !

My configure file for php:

./configure
           --prefix=/usr/local/php
           --cache-file=configure.cache \
           --with-apache=/usr/local/apache \
           --with-oci8=/home/oracle/u01/app/oracle/product/8.1.6 \
           --enable-track-vars \
           --disable-debug \
           --without-gd

Nothing special in php.ini file (nothing about oracle)

And the same for apache:

      ./configure
          --prefix=/usr/local/apache \
          --logfiledir=/var/log/httpd \
          --runtimedir=/var/log/httpd \
          --activate-module=src/modules/php4/libphp4.a \
          --enable-module=rewrite \
          --enable-module=info \
          --enable-module=usertrack \
          --disable-module=include \
          --disable-module=autoindex \
          --disable-module=imap \
          --disable-module=userdir

Thank you

Francois-Xavier Joos

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-27 21:39 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-07-28 16:15 UTC] thies@php.net
    please relink your apache adding -lpthread to the LDFLAGS.
 
    the problem here is that a executable thats *not* linked
    agains -lpthread cannot load a shared library that is liked
    against -lpthread. (libphp4.so - linked against -lclntsh
    linked against -lpthread).
 
    this is a glibc-2.1 bug that supposed to be finxed in 2.2 (i
    heard).

 [2000-07-28 16:15 UTC] thies@php.net
    please relink your apache adding -lpthread to the LDFLAGS.
 
    the problem here is that a executable thats *not* linked
    agains -lpthread cannot load a shared library that is liked
    against -lpthread. (libphp4.so - linked against -lclntsh
    linked against -lpthread).
 
    this is a glibc-2.1 bug that supposed to be finxed in 2.2 (i
    heard).

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 26 14:01:24 2020 UTC