php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53771 Apache 2.2 will not start with Interbase enabled
Submitted: 2011-01-17 23:49 UTC Modified: 2011-01-18 08:55 UTC
From: jackmason at mindspring dot com Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.3.5 OS: Windows 7
Private report: No CVE-ID: None
 [2011-01-17 23:49 UTC] jackmason at mindspring dot com
Description:
------------
Adding "extension=php_interbase.dll" to the end of php.ini causes Apache 2.2 to fail to start ANY services. Without "extension=php_interbase.dll", ibase_connect fails as an undefined function, so Interbase is not enabled as a service by default even though php.ini contains the basic defaults such as "ibase.allow_persistent = 1".

This system is also running PHPEd, with its associated PHP which works fine. When bypassing Apache and confining the pages to PHPEd, everything works.  The "extension=php_interbase.dll" is in the PHPEd php.ini.  The InterBase server is running on this system, and PHPEd has no trouble finding it without any explicit directions.

Either there is another way to enable InterBase on 5.35, or something is wrong. 

Test script:
---------------
$DBUser='MAINUSER';
$DBPass='MAINPASS'; 
$DB=ibase_connect('127.0.0.1:C:/SDB/George.gdb', $DBUser, $DBPass);

Expected result:
----------------
ibase_connect should be recognized as a valid function.

Actual result:
--------------
ibase_connect is declared an undefined function.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-18 04:50 UTC] aharvey@php.net
-Status: Open +Status: Feedback
 [2011-01-18 04:50 UTC] aharvey@php.net
Have you followed the instructions at 
http://php.net/manual/en/ibase.installation.php -- in particular,
ensuring that gds32.dll is in the PATH?
 [2011-01-18 08:55 UTC] pajoye@php.net
-Status: Feedback +Status: Bogus
 [2011-01-18 08:55 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The Firebird libraries are required to use interbase extensions. They have to be 
in your PATH. Test it under CLI to see the error (DLLs not found) or enable/read 
apache's error log.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Mar 31 10:01:25 2020 UTC