php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53609 $_POST failes to populate
Submitted: 2010-12-25 20:20 UTC Modified: 2013-02-18 00:34 UTC
From: michael at tuxgames dot com Assigned:
Status: No Feedback Package: Variables related
PHP Version: 5.3SVN-2010-12-25 (snap) OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-12-25 20:20 UTC] michael at tuxgames dot com
Description:
------------
PHP's php.ini can be configured in a valid way that causes $_POST to stop 
populating.

upload_max_filesize = 6000M
post_max_size = 8000M

Setting these values too high (in this case to allow a DVD upload) caues $_POST 
to just be an empty array()

Changing them to 60M and 80M respectively it all works again.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-25 21:00 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2010-12-25 21:00 UTC] cataphract@php.net
Is this in a 32-bit build? In any case, not that you should be able to set the ini settings to 0 to deactivate the check.
 [2013-02-18 00:34 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 12:03:36 2021 UTC