|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5347 After running configure, make fails
Submitted: 2000-07-03 23:16 UTC Modified: 2000-07-28 10:49 UTC
From: jesus at cnnw dot net Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0 Beta 4 OS: BSDi 4.01
Private report: No CVE-ID: None
 [2000-07-03 23:16 UTC] jesus at cnnw dot net
I have mysql-3.22.32 and apache_1.3.12 and both installed without problems.
My gcc is gcc version  I have tried to upgrade to a newer version of gcc
but, without success.

I ran configure with the following parameters:
[ 529 hunk->php-4.0.0 >./configure --with-mysql=/usr/local/mysql --with-xml\
 --with-apache=../apache_1.3.12 --enable-track-vars\

There are no errors with the configure script.  When I run make I get the following errors
[ 529 hunk->php-4.0.0 > make
"Makefile", line 39: Need an operator
"Makefile", line 40: Need an operator
"Makefile", line 41: Need an operator
Fatal errors encountered -- cannot continue

Here are the appropriate lines from Makefile
include $(top_srcdir)/build/
include $(top_srcdir)/build/
include $(top_srcdir)/build/

I have tried placing = between 'include' and '$'  and then it fails on the next line.
        @$(LIBTOOL) --silent --mode=install cp $(phptempdir) / >/dev/null 2>&1
The error is 
[ 531 hunk->php-4.0.0 > make
--silent: not found
*** Error code 1

If someone could share some light on this I would be very grateful.

Jesus Duarte
UNIX Sysadmin


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-27 20:31 UTC]
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-07-28 10:49 UTC]
closed due to positive user feedback "geting a newer version of make (GNU Make version 3.79)" fixed the problem

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 14:01:29 2024 UTC